TechSpot

No sound from pc speakers

By mcloud
Nov 24, 2005
Topic Status:
Not open for further replies.
  1. Hi chaps,

    Have a peculiar problem with an Evesham Evolve pc. Just checking it out for a friend to sell on and all working fine apart from one little problem. These pcs were a bit of a one off, I believe, with a flat screen on a pedestal with built in speakers and dvd, almost a laptop. Has a 750mhz Pentium proc with 248mb ram and a 20 gb hard drive. The problem is with the sound. It has an SiS audio card and appears to be "working properly" under properties, but can get no sound when playing dvds. Windvd was originally loaded, but coming up with page fault errors, so uninstalled and installed, but still with same problem. Loaded Powerdvd and plays dvds okay, but with no sound. Also the same with plugging in some standalone speakers. I noticed from the outset that there was no volume trumpet on the bottom taskbar and when you go to volume control via accessories/entertainment and click, nothing happens. Strangely when loading a cd, it plays with sound from the built in and standalone speakers, but only thru Powerdvd. When running media player error message received "Cannot playback the audio stream no audio hardware is available or the hardware is not responding". Had a look on Microsoft site and advises to go settings/control panel/multimedia and then 'advanced' to access the Audio device devices, but the advanced part is all greyed out. Is it a matter of loading device drivers or there something more sinister? Any advice appreciated thanks.

    :wave:
  2. DonNagual

    DonNagual TechSpot Ambassador Posts: 3,566

    Do you know what make/model the motherboard is? If you don't you can download this program:

    http://www.techspot.com/downloads/433-everest-home-edition.html

    to probe your computer and get the info for you.

    Once you know the make/model, try going to the maker's website and downloading the driver's for that sound chip. You could also download the driver directly from Sis (www.sis.com) once you know what the soundchip model# is.

    I think that will fix you up! Let us know how it goes.
  3. mcloud

    mcloud Newcomer, in training Topic Starter

    Thanks for the advice.
    Uninstalled and installed sound driver from driver disk supplied with system, but still with no sound from dvd. Also as you suggested got full spec of mb and soundcard and downloaded SiS 7018 driver from Driverguide website, but still no sound. The peculiar thing is still that anomaly of when playing a music cd it plays, but not through Media player. Instead the Powerdvd screen loads and it plays through that and can also change tracks etc. Noticably the volume does not work. Can only change volume with the physical wheel switch on the side of the screen. Feel a bit stumped now. Have been trying to connect through my Telewest Broadband software to try and do some online diagnostics with the various tools available, but can't get connected. Get so far with software load, but cannot establish a connection when plugging in the Usb cable. Have just bought an Ethernet cable to see if that works, but this is all another story.

    puke:
  4. mcloud

    mcloud Newcomer, in training Topic Starter

    Hi again,

    Have sorted problem. It was a driver issue of course and I feel a bit dumb. Made the mistake of running the setup file from the Device drivers disk under Audio and this loaded a SiS7018 driver which appeared correct, but I needed to go into the Win98SE folder where there resided a driver called SiS7018dos and when this loaded all was fine. Thanks for help.

    :eek:
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.