No Sound On My Pc

By bellamisty
Aug 26, 2005
Topic Status:
Not open for further replies.
  1. Hi - I have all a sudden lost the sound on my PC... Can you help me- I am not sure what to do...
  2. Blakhart

    Blakhart Newcomer, in training Posts: 510

    Are all the plugs in the right socket?
    Have you tried headphones to rule out bad speakers?
    Does the system show sound to be enabled in device manager?
  3. bellamisty

    bellamisty Newcomer, in training Topic Starter

    Hi Blackheart - I double checked everything from the mute option to upluging and plugging back in.... to checking the devise manager. But I am going to double check when I get home- Stay tuned!

    Thanks so much!
  4. Blakhart

    Blakhart Newcomer, in training Posts: 510

    Hi
    If it has an onboard sound device such as a realtek sound chip, I have seen the same prob before.
    It showed up in device manager and showed enabled with no problems even tho it had no audio output. What I did to fix it was delete and reinstall the driver, using realteks latest driver. Worked fine since, and I have no idea what happened to cause it in the first place.
  5. bellamisty

    bellamisty Newcomer, in training Topic Starter

    Hi - It is a seperate card made by turtle beach (mantegoII). What do you think?
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.