TechSpot

Not acquiring IP from DHCP thus, limited or no connectivity

By xthejess
Feb 5, 2006
  1. My sister's computer is connected via ethernet cable that runs from our linksys router to my computer. All of a sudden her connection becomes limited or none at all. I've eliminated all hardware problems, her cables work, her nic card works, my router works. So I know it's not our cables and router.

    I've tried the ipconfig dealies, it still cannot acquire an IP. I've tried manually setting up the IP through TCP/IP and still no luck?

    Am I doing something wrong?
    Confused....
     
  2. DonNagual

    DonNagual TechSpot Ambassador Posts: 2,404

    I'm confused. It sounds like she is able to connect, yet you go on to say she can't get an IP?

    Assuming she CAN connect, but it is kicking her off.....have you tried updating her NIC drivers?
     
  3. xthejess

    xthejess TS Rookie Topic Starter

    Somehow it does.

    In windows xp, when you're connected to the network, the icon shows in your task bar. when you click hers, it says limited or no connectivitty. When you try to "repair" which pretty much is release and renew her ip, it says it can't connect to the DHCP server to get an ip. ???

    I know it doesn't make sense..but that is what it's saying.. :confused:
     
  4. tipstir

    tipstir TS Ambassador Posts: 2,392   +107

    NIC Help

    Un-bind the NIC
    Do this..

    Right click on properties for NIC your using settings in: connect to: show settings Uncheck every check box then then hit okay
    Then wait..
    Go back and check them again...
    open a dos prompt window
    click on run then type: cmd
    type: ipconfig /flushdns
    type: ipconfig
    if you still come up blank

    Remove the drivers for this NIC and then try Rebooting the PC

    Go into your BIOS and make sure onboard NIC is disabled if you're not using one, if you are make sure it's enabled. If you're not using IR port disable that also in the bios. If you're not using wireless onboard if you have it or not disable it.

    Once back in XP check to see if you're connect? If not go back into the BIOS and disable the onboard NIC. Buy yourself a NIC (PCI) and use that instead.
     
  5. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

    disable dhcp in router
    set all your nics to static you will never have to worry about dhcp ip address release renew again
    accept of course for the WAN side
    router ip default 192.168.1.1
    lan ip in first nic
    192.168.1.100
    255.255.255.0 subnet
    default gateway 192.168.1.1
    check router status for your WAN DNS ip's
    plug'm into the DNS at bottom
    this is all under tcp/ip properties
     
  6. xthejess

    xthejess TS Rookie Topic Starter

    how do I change my routers IP to static? I don't nkow how... and i figured out why my sisters internet isn't working it was the stupid cat5 she broke.

    but now my laptop which runs on a wireless-b linksys card, isn't working. Even if I unplug the card, and connect use a patch cable directly from my router, it says limited or no connectivity.. ughhhhhhhhhhhhhhhhhhhhh

    :( :mad:
     
  7. Jimbo420

    Jimbo420 TS Rookie Posts: 356

    Have you tried moving the cable to different ports or rebooting the router? Could be that it is starting to fail.
     
  8. xthejess

    xthejess TS Rookie Topic Starter

    Yesssir. Ive removed all cables from the ports and rebooted the router a number of different times.

    AlthoughI haven't tried disabling DHCP because i don't really know how..
     
  9. Jimbo420

    Jimbo420 TS Rookie Posts: 356

    Not really hard just log into your router and there should be a section for DHCP. Simply turn it off. However when you do that you do need to hae all of your computer set up with valid static internal IP address for you router.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...