TechSpot

Nvidia Drivers do nothing

By Raidur
Aug 19, 2008
  1. Hey guys and thanks in advance. A friend of mine is trying to install my old 7950GT 512mb into his freshly reformatted computer. He has told me that he tried installing the proper nvidia drivers and after restarting it made no difference. He said the windows are still glitchy and the resolution and color bit still stay the same, as if there were no drivers installed. He also said he tried installing the drivers from the EVGA website as well (it was an EVGA card). I didn't have him look in the Device Manager to see if it was in there but I will and update this post. I haven't looked at it myself but figured I'd get some ideas before I do, so I can save some time when it comes. =P

    Could the card be dead/dieing? Is it possible for ram/cpu/mobo to cause this to happen?

    Thanks again!
     
  2. nickc

    nickc TechSpot Paladin Posts: 923   +11

    yes the card could be dieing. and yes the mobo could be causing this but more unlikely.
     
  3. Raidur

    Raidur TS Rookie Topic Starter

    Ok I'll test the card out on my computer later and let you know if it works. If it works on my pc do you think it is most likely the mobo causing the issue?
     
  4. Darth_Terra1

    Darth_Terra1 TS Rookie Posts: 212

    It could be a number of things, what is the spec of the sytem he's trying to install the card into, does it have a power supply capable of running the card.
     
  5. CCT

    CCT TS Evangelist Posts: 2,653   +6

    He re-formatted his comp.

    Did he install the chipset drivers?

    When he booted up, did the Plug and Play system see the 'new' vid card and ask for drivers?

    edit:

    Did he connnect the additional power supply to it? (similar question to the above but having it and connecting are diffferent - lol)
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...