On computer startup, monitor led flashes green then amber but no display

By Mazrim
Oct 7, 2014
Post New Reply
  1. Just started happening yesterday. I shut my system down each night, and this morning, I fire my rig back up only to find that my monitor (an Acer AL2216W model) wouldn't display anything, but the green power LED on the monitor's power button kept flashing from green to amber, then back to green over and over again.I tried powering it off, then back on again, and nothing happened. I tried unplugging the monitor from power and back in again, but nothing happened. Then I unplugged the monitor from my video card, then back in, and after a few seconds, my display was back.

    So now I'm wondering if it's the monitor itself that's going bad, or if my video card is bad. Since power on and off and unplugging from power didn't work, but unplugging/replugging the input did, I'd like to think it was my vid card (and it's under warranty so I can RMA it), but I wanted to find out what you guys thought about the problem.

    Any advice is very much appreciated!
  2. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,233   +234

    Does the computer have more that one place to plug in a monitor?
  3. Mazrim

    Mazrim TS Enthusiast Topic Starter Posts: 113

    Yes. I run an EVGA Nvidia GTX 760 2GB, that has 2 ports on it.

    I tried the 2nd port on startup just now, and I still get the same problem.
  4. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,233   +234

    Can you try another monitor?
  5. Mazrim

    Mazrim TS Enthusiast Topic Starter Posts: 113

    Ok, tried another monitor, and it fired right up, so my monitor is the culprit.

    *sigh* here goes ANOTHER $250+ for a 22" LCD.......

    Thanks for your help! :)
  6. Tmagic650

    Tmagic650 TS Ambassador Posts: 17,233   +234

    Good work, and thank you for visiting us:)

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...