TechSpot

On my wireless network, all my computers have internet access except for one.

By MXB
Aug 9, 2007
  1. Hey, I have a home wireless network for two XP PC's and one XP laptop. One of the PC's and the laptop both have internet access through my comcast internet and linksys routers, but the other PC wont connect. Ive tried unplugging and re-plugging the routers, and re-booting. I can connect to the network (it says connected with very good signal) but I can't get on the internet.both of my other computers are on the same network but they can connect just fine. I dont know any computer language so please only use 'noob' terms. Thanks so much for the help, it is greatly appreciated!

    -MXB-​
     
  2. Keerimen

    Keerimen TS Rookie

    Well, I've experienced something similar, but to fix it you'll have to do some things that aren't too hard...

    Try going on to you're router's web based configuration page and change the IP (I'm guessing that the default is 192.168.0.1) to 192.168.0.2

    That might not work, and knowing me, I wouldn't bet on it, so, maybe you should try changing channels on your router to avoid any interference. Try changing it to 11, that helped me in other areas I can remember.

    Have you gone on the PC and checked the wireless on there? It says its connected you say, so in the task bar should be a little icon meaning Wireless is detected (And hopefully connected)

    Try right clicking that, and going to Status, then Properties. There should be a new window that comes up, with a list of things with check boxes. Scroll there, and find something called "Internet Protocol (TCP/IP)". Once there, make sure that "Obtain IP Address Automatically" and "Obtain DNS Server Address Automatically" are checked.

    I don't know what else to tell you if that doesn't work, other than upgrading firmware of your router, which is fairly easy.

    Best of luck.
     
  3. k.jacko

    k.jacko TS Rookie Posts: 743

    All as Keerimen has suggested.
    Although i don't its anything to do with firmware. Neither a channel issue, unless your wireless card is a little weird and defaults to a different channel.
    Check that all the wireless cards (whether in-built or not) are of the same 802.11 protocol. Probably 'g' (802.11g). Make sure all cards supports wireless g and that the router is set to broadcast 'g'.

    You can also open a command prompt and check the ip credentials.
    Start > Run > [type in] cmd
    When the dos window open us, type in> ipconfig /all
    It will tell you all the relevent tcp/ip details of the network adaptors on you pc. Obviously the wireless one is the one you're interested in. The ip address should be in the range of 192.168.0.x (basically the 1st three numbers should be the same as the router and the other 2 pc's). Only the last digit will differ.
    The DCHP server should be the IP address of your router, eg. 192.168.0.1
    If these are not reading like this then you certainly do have a problem.
    Also check in the router config page in a browser that your DHCP lease range allows for more than 3 addresses. ie. you have 3 pc's wanting to connect so set the range to say, 5. Which means that it will hand out 5 ip addresses so 5 devices can connect to it.
    If the ipconfig reports that you do have an ip address in the correct range, then check your windows firewall settings (turn it off). See if you can browse the network and see the other pc's.
    If you can and the only thing you cannot do is connect to the internet, then we need to look at different things. I had the same problem once, can't remember how i sorted it though.
     
  4. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,714

    Your router allocates IP addresses to your network machines, without which there is a connection but no network. If a PC is not allocated an IP address it has a default IP address which it will try and use instead, but if it is not in the correct range it will not connect to the router.
    On each machine
    Start > run > cmd > OK
    At the prompt type ipconfig <enter>
    you should see something like this:
    ethernet adapter local area connection #:
    connection-specific DNS suffix .:
    IP address 192.168.1.2
    subnet mask 255.255.255.0
    default gateway 192.168.1.1
    the router is the default gateway and allocates itself an IP address; all other IP addresses are in a range usually above this number - so the IP address allocated to the PC you are working on in this case is 192.168.1.2.
    Check on all your machines that you have a similar report - the gateway number can vary (sometimes 10.0.0.2) but the rules stay much the same.
    I'll bet the machine without a network is showing no value for the gateway and the IP address is not in the range.
    Try this and tell us what you find
     
  5. k.jacko

    k.jacko TS Rookie Posts: 743

    a posher way of saying what i just said then :rolleyes:
     
  6. AlbertLionheart

    AlbertLionheart TechSpot Chancellor Posts: 2,714

    odd that - I thought your instructions were better than mine. But posh? - I think not, dude.....
    Still, MXB has not come back to us on it yet so maybe between us we did the right thing?
     
  7. k.jacko

    k.jacko TS Rookie Posts: 743

    Lol, lets hope, cos we made it sound like we knew what we were talking about didn't we? :suspiciou
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.