Optical drives not detected in BIOS

By jiffypop
Aug 29, 2005
  1. Hi, I've just built my own PC for the first time. It has a SATA HDD (Western Digital WD400), a DVD/RW (Pioneer DVR-109) and a DVD-ROM (Pioneer DVD-120RD). My motherboard is Asus P5GD2 Premium. The HDD is connected via a SATA cable in the SATA1 connector in the motherboard, and the optical drives are connected via an Ultra ATA ribbon cable in the Primary IDE RAID connector. The jumpers are currently set as thus: HDD - cable select, DVD-ROM - slave, DVD/RW - master; although I have already tried swapping them around. When I turn the computer on, it does an IDE scan and detects the DVD/RW and DVD-ROM as being 'Drive 0' and 'Drive 1' respectively. It doesn't show the HDD. Then when I go into the BIOS, only the HDD appears, as 'Third Master IDE'. Because it doesn't detect the optical drives, I can't install WinXP. What's going on?!
  2. urbandragon

    urbandragon TS Rookie Posts: 231

    ok. you have 1 hdd via sata correct..

    why not use both ide channels for your optical drives.

    set them both to cable select and put them on their own IDE cable
  3. jiffypop

    jiffypop TS Rookie Topic Starter

    OK, I've just tried that, but it's still the exact same problem - the optical drives will show up during the IDE scan at startup, but they are 'undetected' in the BIOS.
  4. mailpup

    mailpup TS Special Forces Posts: 6,964   +355

    I'm a little confused about what you said regarding your HD. Western Digital does not advise changing the jumper settings from default for ordinary desktop use. I don't think cable select is even an option for SATA but, nonetheless, did you change jumper settings on the HD?

    Also, did you go into the BIOS and enable the SATA controllers (possibly under IDE Devices Configuration depending on which BIOS you have)?
  5. urbandragon

    urbandragon TS Rookie Posts: 231

    His problem is not with his hdd as he stated. it is with his optical drives being recognized, the SATA and IDE are 2 completely different controllers.

    one other thing that may be happening here is your IDE contoller may be disabled in bios due to your use of the SATA hard drive.

    Go into bios and enable your IDE controllers.
  6. mailpup

    mailpup TS Special Forces Posts: 6,964   +355

    Yeah, I addressed an OT side issue and then went off on a tangent.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...