TechSpot

"Orphan file records" on Win2k SP4

By Obby
Nov 27, 2004
  1. Hi,

    Running a P4 2.4ghz on an Abit BD7-II RAID mobo, with a 60gig maxtor on the primary IDE, and a new (2 months or so old) 160gig Western Digital on the raid.

    The 160gig is partitioned into two lots of about 75gig, and the second partition is having problems.

    Windows hangs when copying files to the drive after a certain point (or so it seems to me..) It will let me move gigs and gigs of stuff until a point and then it'll just hang every time I try to copy anything.

    Have tried running chkdsk on it, and I get a lot of 'deleting orphan file record segement' messages, from 4182 to 5372 non-continuous.

    Then it'll verify the indexes, and try to 'recover lost files', it gets so far and then an 'unspecified error' occurs.

    This is all with chkdsk run with the /f param, and I've not found anything else that'll help me. MS Support is devoid of info on this, too.

    Hope someone can help, thanks in advance :)

    -Rich
     
  2. Didou

    Didou Bowtie extraordinair! Posts: 4,274

    With HDDs above a certain size (137GB I believe), you need for 48 bits LBA to be activated.

    Microsoft Support Link
     
  3. waterbee

    waterbee TS Rookie

    EnableBigLBA and images restoring

    Hi All,

    I have found how I got the 'deleting orphan file record' errors. I upgraded my drive for a 160GB harddrive in XP and had to set EnableBigLBA to acces the drive beyond the 137GB barrier. After that I restored a backup of XP without this setting and that;s why chkdusk started deleting the partition. XP can't mount that partition anymore and that's why I have to restore a backup. I'm pissed at those who put this kind of switches in an OS and then 'forget' about chkdsk behaviour. grrr.

    [edit]
    I have converted my drives from FAT32 to NTFS and after making sure I have everything backed up, forced chkdsk without the EnableBigLBA setting in registry to check the disk beyond the 137GB barrier. With NTFS partitions it seems that the EnableBigLBA setting is not necessary. There was only one difference with my test and the dead partition, I only put a couple of thousand files on it. I don't feel like testing it with alle the data but it does make sense.
     
  4. songws

    songws TS Rookie

    EnableBigLBA and images restoring

    Hi Waterbee,

    How do you set EnableBigLBA to acces the drive beyond the 137GB? I hope you can share with me.

    Many thanks.

    Regards,
    SONGWS :wave:
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...