PC Won't Switch On!

By datasafe
Mar 17, 2007
  1. Hi guys

    My first post here and I'm seeking help!

    My PC has been working fine for months (since new).

    It has an Aopen AK86Lmotherboard with an AMD Athlon 64 3200 processor.

    I was using my PC this morning and it just switched off! I thought there hd been a power break but no.

    I tried switching the PC back on, there was a quick flash of the power LED but that was it - NOTHING.

    I removed the side panel and noticed a red LED on the motherboard was illuminated.

    I tried to switch the PC on again, the power LED flashed and the CPU fan twitched but that's about it!

    I thought it was likely to be a power supply problem so I replaced the power supply with a new one, made off all the connections correctly, connected the mains power lead, the red LED on the motherboard illuminated. I switched on from the front panel switch. Once again, the power LED flashed and the CPU fan twitched, but that was it - the red LED on the motherboard remained lit.

    Any ideas guys?


  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    Since a new psu hasn`t solved your problem, I`m afraid it looks like your mobo has died.

    Maybe your other psu went bad and took out the mobo, it`s not uncommon.

    Regards Howard :wave: :wave:
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...