TechSpot

Photoshop runs slow on laptop

By pinkpinkstars
Dec 27, 2010
Post New Reply
  1. So I got a new laptop for christmas and I want to use photoshop cs5 on it. I try it out today and it lags when I'm drawing, Why does it run smoothly on my old 3-4 year old desktop computer and lags on this new laptop?

    What I mean by lag is for example I'm drawing a circle, the cursor doesn't follow the speed that I am drawing at and the circle comes out jagged. Whereas on my desktop it runs just fine, a smooth round circle.

    My computer hasn't been upgraded at all with added ram or any of the sort. Anybody have any idea how can I fix this? :\

    My laptop is a Toshiba Satellite Model: L675D-S7052
     
  2. Inforanop

    Inforanop TS Rookie

    Shared memory.:( Most mainstream laptops use onboard memory for both the OS and the video.
    It always works out slower,no matter how much memory you have.Games,video and photoshop are video intensive.
     
  3. captaincranky

    captaincranky TechSpot Addict Posts: 11,702   +1,886

    The latest versions of Photoshop, (CS-5), include hardware acceleration for video. The consequence of this, is that it probably never will run its best on a laptop, and requires a decent add in video card in conjunction with a desktop, to get the best from this program.

    That said, Adobe is becoming ever increasingly disdainful of controlling minimum hardware requirements, for their now quite bloated programs.

    In the interest fairness, Photoshop is still a world class, if not the best image editing program available. But, each new release does raise the bar, so to speak, for the computers it is to be run on.

    Older versions never ran their best on older laptops either, and so it goes.
     
  4. Technochicken

    Technochicken TechSpot Paladin Posts: 729

    If you laptop has a decent CPU, it may be able to render your drawing faster than your GPU can. I found this to be the case on my computer. You can disable OpenGL drawing by going to "Preferences" and the "Performance" and unchecking the tick box. The downside to this is that it disables smooth zooming.
     
  5. hellokitty[hk]

    hellokitty[hk] Hello, nice to meet you! Posts: 3,435   +145

    Laptops are weak, there is nothing "wrong" per se.
    Do try turning off OpenGL, but remember that your laptop is not necessarily better. Portability comes with it's downfalls.
     

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...