TechSpot

please help pc wont turn on

By shalashaska123
Aug 9, 2007
Topic Status:
Not open for further replies.
  1. last september i built my own computer and it has worked until now. Recently my computer would not turn off even when i commanded it to, so i have had to turn it off manually. today it was working until i was playing a game, fear, and the game froze. i turned off the computer manually and proceeded to turn it back one, and it wouldnt. none of the fans would spin, none of the lights or leds worked, and my router does not indicate thecomputer as connecetd as it usually does when its off. lastly, when my computer was off but working, before this happened, one green indicator light would stay on in the computer, but now it is not. i believe the issue is either the mobo or psu, but i dont know for sure, nor do i know how to test it. please help, i would be grateful!!!!
     
  2. shalashaska123

    shalashaska123 TS Rookie Topic Starter

    well now its morning and mobo green led will turn on now. unfortunately the computer itself wont turn on, and the router still does not recognize the computer as being connected, please help me
     
  3. Cinders

    Cinders TechSpot Chancellor Posts: 1,313   +12

    Hello Little Monkey! <--- Ignore that if you don't understand the reference. Sounds like your PSU is KAPUT! Just borrow a friends PSU if you can and see if that solves the problem. If it doesn't then you need to replace your motherboard.

    I'm guessing this will do unless you have a large SLI or Crossfire setup. I have a smaller Crossfire setup and this works for me. Purchase the above or something alot like it.
     
  4. shalashaska123

    shalashaska123 TS Rookie Topic Starter

    hey ill check if that works, but one question, to anyone, could any thing else make my computer not turn on?
     
  5. Cinders

    Cinders TechSpot Chancellor Posts: 1,313   +12

    A broken power button would keep your computer from powering up but that would not interfere with the status light on the motherboard.
     
  6. shalashaska123

    shalashaska123 TS Rookie Topic Starter

    i decided to go into the old girl now and disconected everything and plugged back in. now the computer will turn on where the fans run on most of the components, but the actual computer wont boot up. everything seems to be working except the leds on my ram are not lighting up. possible problems?
     
  7. Cinders

    Cinders TechSpot Chancellor Posts: 1,313   +12

    Same problem different symptom. I still think the PSU is at fault. You can take out your memory and try booting your computer. If your motherboard is still working correctly you should get some beep codes that indicated you don't have any memory installed, but if your power supply is truely broken then you can't rely on what your motherboard tells you because who knows what will still run correctly if the voltage/amperage isn't correct.
     
  8. shalashaska123

    shalashaska123 TS Rookie Topic Starter

    guess ill try and find a another psu and check back here later, thanks for advice so far
     
  9. shalashaska123

    shalashaska123 TS Rookie Topic Starter

    k, have not tried new psu yet, but could someone explain why the fans and psu fan will turn on, or the mobo light is green while the computer wont boot up?
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.