TechSpot

possible ATI driver issue in Quake 4 need help

By OpTiMuSpRiMe
Jan 11, 2006
  1. i have been having some wierd issues with Quak 4 that i have recently bought.. i have a rather nice system for it being a 478socket... but still it run very nice.. any way the issue is with the FPS sticking at no more than 90-100 FPS and sometimes the game will have what look like memory buffer overflows but it's not.. and also it will look to be having rendering issues like the color goes green on a border and then the lighting will start to flicker. I play HL2 Ut2004 and CSsource and Far Cry all on the highest setting capable for the game and i have never had this kind of issue or any to be honest they play great.don't know if anyone has a clue as to what the problem would be but some ideas would be great... thanks alot techspot gurus
     
  2. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,764

    Get the latest driver from ATI and any patches or updates for the game. ATI cards dont handle the Doom 3 engine very well.
     
  3. OpTiMuSpRiMe

    OpTiMuSpRiMe TS Rookie Topic Starter Posts: 211

    see and i have done that as well as reinstalling the game numerouse times and it still does it. and i also play doom 3 on max settings and i have not encountered the same the issue that i have in quake 4... i am thinking that it is the game.. i have done everything that you can think of to change the things that are happening and to no avail.thanks for the quick response though :)
     
  4. Baltan

    Baltan TS Rookie Posts: 250

    how about buying trying the same game but with a different cd and seeing if you encounter the same problems??? Maybe its just the cd or that particular game does not work!
     
  5. peterdiva

    peterdiva TechSpot Ambassador Posts: 1,202

    Set the game's max FPS back to the default 60 and see if you still have the same problems.
     
  6. OpTiMuSpRiMe

    OpTiMuSpRiMe TS Rookie Topic Starter Posts: 211

    see and that is what the weird thing is... i have not changed the FPS in the game at all.. it is all default.. the only thing that i change was the resolution to 1600x1200 at 85z and it looks great just every once and awhile the lights in the game flicker wierd and there is this annoying screen flicker in the middle of the screen like there is a refresh rate issue and there isn't by the fact of what i have my screen settings at. i have no overclocking done on the proc or the vpu just stock settings.. not a really big fan of cutting expensive components lifes in half with overclocking.. no affense to anyone..personal thought only.. any way thanks for the tips guys and i will keep working on this one...any more tips or suggestions please let me know
     
  7. peterdiva

    peterdiva TechSpot Ambassador Posts: 1,202

    If you haven't seen it already Quake 4.
     
  8. Cartz

    Cartz TS Rookie Posts: 97

    Turn VSync On

    The tearing you're seeing is because you're running at 85Hz and your video card is sending it data at 90-100Hz...
     
  9. OpTiMuSpRiMe

    OpTiMuSpRiMe TS Rookie Topic Starter Posts: 211

    so thearetically i should be seeing the tear in all my games if my video card is sending data at the rate you stated if my monitor is not displaying at that rate too right?? thanks for the tweakguide i didn't even think about getting one.. i used one for doom 3 so it should be the exact same commands except a few... thanks guys will let you know
     
  10. Cartz

    Cartz TS Rookie Posts: 97

    Not neccesairily, some games will set your monitor to the highest refresh rate possible, or your video card may not be able to keep up with the refresh even at 85hz... Other games have vsync turned on by default, you may not even have noticed.

    Other problems you've noted may not even neccesairily be caused by Vsync, but I thought it was a good (and most obvious) place to start.
     
  11. OpTiMuSpRiMe

    OpTiMuSpRiMe TS Rookie Topic Starter Posts: 211

    if you check my specs of my system u can see that i have the Radeon X850XT PE 256gddr3 video card and i am very sure that i can more than handle Quake 4 at any speed or resolution.. i mean i use the same settings in doom 3 with no issues and they are both using the same engine.. that is why i am having so many questions to ask about why it would be doing that... thanks for the link Peterdiva that help alot.. i will try the setting recs in that article and go from there.. you guys have been more than helpful thanks alot :)
     
     
  12. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,764

    Im using the Quake 4 demo to test new system builds and havent had any problems except I did need to download a patch from Creative because there was a problem with the game and the sound driver. See if there is something like that for your audio. A problem with the audio driver can cause the problems you're having.
     
  13. mastronaut

    mastronaut TS Enthusiast Posts: 185

    I'm really curious why so many people are having issues with Quake 4.
    I gave Doom 3 to my brother because it was giving me fits, but I've had no problems whatsoever with Q4. I run an ATI 9600XT 256, it's smooth as silk on high. Then again I'm running 85% (28.8 gigs used on a 120g HD). I think that helps free up resources for my gaming needs. Just my two cents...
     
  14. frankenwookie

    frankenwookie TS Rookie

    I know this is an old discussion, but I am having nothing but trouble getting Doom3 or any using it's engine to run on my pc with ATI X1800XT. It constantly crashes bringing up a blue screen that says that FPU stack is not empty at the end of frame causing everything to shut down. After that everytime I run doom it crashes back to the main menu. It has happened on prey and quake4. I am a huge fan of ati, but after I tried uninstalling every driver on my pc and reformatting for good measure, I finally broke down and bought an Nvidia 7900gt. I just wish I could figure out what the deal is? Here is my set up:
    Asus A8N32-SLI deluxe
    AMD 3500+ 2.2gb
    Nvidia 7900gt(after couldn't get X1800XT or GTO to work)
    WD 250gb HDD
    2gb Adata Vitesta ram
    BenQ combo drive
    Enermax liberty 500w
    Any suggestions would be appreciated.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.