Printing/Spooling Troubles

By technoboy
Apr 3, 2005
  1. Okey Dokey, here we go:

    I have an HP Pavillion ze4560us laptop. My printer is a Canon Multipass F60 (printer, scanner, copier). For some reason I cannot print. I get an error message saying that the Windows (curse it) Print Spooler Service is not running... Uh..Ok.

    I access the services via Control Panel>Administrative Tools>Services, and start 'er up. The service starts, but it still gives me the same error message.

    Then I wonder, could it be due to my recent hardware upgrades. I recently added a PCMCIA 4 port USB 2.0 card bus. So I eject the PCMCIA card, pop by printer cable out of it and into one of my built in USB ports. Still no. I've tried rebooting each time after all these things, but no. Now I don't think this is any problem with by printer, because, Windows (curse it) detects my scanner, which is still fully funtional, and I can still make copies. So I think this has something to do with Windows (curse it).

    So any help?? Post any questions if I left out some information you need.


    P.S. I do have a firewall (Zone Alarm Free), but I tried it with it off, so it's not that. And I have had my printer for a long time and it has been fine, so it's not like I just bought it.
  2. technoboy

    technoboy TS Rookie Topic Starter

    Worse yet...

    Okay, things are getting even worse. Upon booting up it now takes several minutes to logon. Then, for several minutes I see only my wallpaper and the mouse arrow (which moves and all like normal)- no taskbar, desktop icons, nil for several minutes. I'm free of spyware, and virus, so say my various scanners. But it gets worse still.

    NOW, Windows System Restore will not run- at all. HELP!!!
  3. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Does your RPC service run?
    Have you done an AV-scan recently, your PC could be infected.
  4. technoboy

    technoboy TS Rookie Topic Starter


    I have the latest virus definitions and have scanned and found nothing. And what is RPC service?
  5. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    RPC is Remote Procedure Call
    Go to Start/Settings/Control Panel. Doubleclick on Admin. Services, select Services.
    Scroll down till you find it. RPC should be set to automatic, the RPC Locator to manual.
    Also, check the Remote Registry Service under it, set that to Disabled.
    All this can be done in the Properties of each service.
  6. technoboy

    technoboy TS Rookie Topic Starter

    Things just went from bad, to badder, to "the-heck-with-this-i'll-just-reformat-and-cry-because-i-have-dial-up-and-it'll-take-hours

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...