TechSpot

Problem with detecting the primary slave drive

By tepster
Mar 2, 2005
Topic Status:
Not open for further replies.
  1. Ive tried almost everything to get one of the computers im trying to fix to work. Basically i need the cd rom drive to work so i can install windows and other applications on it. Upon loading, the system detects that there is a harddrive but no primary slave, secondary master, etc. On the cmos all the drives are on "auto detect" which means it should be able to detect the cd rom drive.

    Ive tried the following things to make the cd rom drive work:

    Replacing the cd drive with another, and ive tried this three times and it wouldnt work. Ive also tested the cd rom drives on other computers and they seem to work fine.

    Ive moved the jumpers around; ive put the cd rom drive to slave, primary, etc. Ive also moved the hard drive jumpers around to see if this would have any effect. But no it doesn't.

    Both the cd drive and the harddrive used to be connected to the motherboard with just one cable. I put in another cable and connected the cd rom drive to the secondary IDE and the hard drive to the primary IDE. Still the cd rom drive has refused to be detected.

    It is most definitely not a problem with cd rom drive, and iam now clueless on what to do. Any ideas? Ty for your help :)
  2. tbrunt3

    tbrunt3 TS Rookie Posts: 495

    Do you just have one cdrom and one Hdd?? Try replacing the cable

    Go to your bios and change the boot order to read the cdrom first.

    let us know
  3. 4n75

    4n75 TS Rookie

    Try this

    Hi there

    Most of the time when i have a problem like this i upgrade the BIOS and then the problem goes away ... try it :)

    Ants
  4. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 8,165

    CD-drives don't like 80-wire flat-cables. Use an older 40-wire cable and put the CD as master on the second IDE-channel.

    And make sure that the red or blue wire is at position 1 of the connectors!
  5. luvhuffer

    luvhuffer TechSpot Paladin Posts: 638

    When you set them to autodetect, hit enter to detect them. Or set them to CDROM. What OS are you trying to install? Are you setting the boot order to CDROM. Try setting all the boot options to CDROM. It sounds like you need some startup floppies. They will install the files needed to make the CDROM detectable so you can continue the install. List the OS and I'll tell you which ones to use.
  6. tepster

    tepster TS Rookie Topic Starter Posts: 22

    Well its going to be windows 2000, but its not on the system yet lol. Ive tried reseting the boot sequence, but nothing seems to happen. im using a 40 wire cable at the moment so that obviously aint the problem.. But basically after the first screen where it tries to detect the hdd, cdr and how much memory you have, a little phrase saying

    Pipeline burst SRAM comes up. Any idea what that means?

    Basically if its any more help, after that phrase comes up and it tries to load the windows, it just freezes at the end. :\
  7. tepster

    tepster TS Rookie Topic Starter Posts: 22

    Hmm My bios number is PI - 5XTP4. Can someone give me the link for a update so i put it on floppy? That could make it work... unless its a "pipeline burst SRAM" problem hehe.
  8. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 8,165

    That is an old Asus mobo, that I used to have years ago. I sold it (with its manual) about 3 years ago, it was running like a charm in a PC with W98.
    The SRAM is the external L2-cache on the mobo. I had a P120 on it.
    It will run W2K, but only just, and needs 128MB (better=256MB) memory to be any useful.

    On the W2K-CD is a directory BOOTDISK. Run the makeboot.exe to get the 4 startup-floppies, if the CD is not bootable or the BIOS does not support start from CD.
  9. tepster

    tepster TS Rookie Topic Starter Posts: 22

    Well for now im trying to get my computer to detect the Cdr without using any of the w2k files, its got to be a problem with the cmos, well thats my guess, but i cant seem to find a problem. :\ :/
  10. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 8,165

    Reading thu it again. Go to www.bootdisk.com and get the file to make a W98SE bootfloppy. Start that up and run it WITH CD-support. That installs the CDrom-driver that is currently missing. Insert the W2K-CD and start the install.
    I remember now that the CD does not show up in the BIOS, and only works with the proper driver installed (from a bootfloppy or built-in from W2K).
  11. localoasis

    localoasis TS Rookie

    I recently was working on a fresh install of Win XP on a Dell Inspiron 1100 and my CD-ROM drive died mid-install. So now I have a completely empty hard drive and no way to reinstall Win XP. I am trying to use Partition Logic to create two partitions (one for the Win XP files to install and one for the OS once everything is installed). I have created a disk that includes the I386 folder from the Win XP setup CD as well as win51, win51ic, win51ic.sp1, and xpsetup.ibb files (I was told how to create an install CD on some site, can't remember where). The CD works great in another laptop so I know the files are all set up right for an install.

    Right now I have another laptop with a working CD-ROM which I am using to copy all of the setup disk files to the smaller partition on the hard drive. My hope is that I will be able to boot from the hard drive and have win xp installed. I'm a little nervous though because when I type winnt32.exe in the C:\> prompt it says bad command or file not found.

    If anyone knows I can can take the install files and copy them to a HD then put the HD back into the laptop I want to use and install them from there please leave the detailed instructions here. I am way over my head but learning somewhat quickly as I go thanks to various forums, please be very clear in instructions so that they are easier to follow.

    I have tried installing Win XP on the HD using the computer with the working CD-ROM but of course it installs the drivers for that computers mother board which is obviously different from the computer I want to use the HD in.
     
  12. luvhuffer

    luvhuffer TechSpot Paladin Posts: 638

    Firs of all there is 6 different sets of install disks. 3 for XP Home (plain, SP1 and SP2) and likewise 3 for XP Pro. Unless they have SP3 ones now as well. So you need to use the correct ones for your XP CD. These files however don't have XP on them. They only have the files needed to prepare the system to install the OS. They set up the proper drivers and such so the system is capable of installing the OS. They are just temporary files and are removed when the installation is finalized. If you or a friend have another computer with a working CDROM try removing it and just use it to install the system on your computer? None of those scenarios you mentioned sounds workable to me, sorry to say. That or buy another CDROM. You can pick them up (used) for just a few bucks if you have a PC liquidator or even a Goodwill Computer store where you live.
  13. localoasis

    localoasis TS Rookie

    Thanks for the reply. I actually got it working by going about it the way you mentioned about 2:00 this afternoon. I got it close to working the other way but I was missing a few files that it was trying to access (probably the temp files you mentioned), the setup installer was running though!
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.