TechSpot

problem with new hard drive

By troxartas
Mar 16, 2007
  1. hello all....i just got a new 500gb hard drive to use as a backup drive. i was using a USB portable storage device to access my previous drive. when i turned on the USB device with the new drive in it, windows saw it and said it was installed and working, but when i went to my computer to format it, it didn't see it. device manager sees it and says it's working properly, but i can't access it and format it from there. i tried connecting it to the motherboard and bios saw it and device manager saw it, but my computer didn't. i just want to format this new drive and be done with this major headache! let me know if you guys come up with anything....good night all!
     
  2. SNGX1275

    SNGX1275 TS Forces Special Posts: 12,630   +321

    You need to create a partition on it. You can do that through Disk Management in the Computer Management part of the Administrative Tools Control Panel.
     
  3. troxartas

    troxartas TS Rookie Topic Starter Posts: 33

    you are the man! it took me a little while to figure it out, still a novice at this, but i got it. thank you very much for the info!
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.