TechSpot

Problem with old Motherboard

By h0ly_danc3r
Jan 1, 2006
Topic Status:
Not open for further replies.
  1. I have old motherboard epox 693A, but it works :D yes it`s slow and everything . But now after long years of having, my on-board USB connector doesn`t work donno why? I connected the wires exactly as it says in manual but when I try to plug in a USB device it says USB device malfunctioned. Is it possible to repair it or something :confused: ?
  2. PUTALE

    PUTALE TS Rookie Posts: 178

    is it only the 1 usb device or you have tried other device, maybe your device is broken.
  3. h0ly_danc3r

    h0ly_danc3r TS Rookie Topic Starter

    No I tried every usb device that i have and they work normal on usb on the back of the computer.I think it has something to do with power because when i plug in it says malfunction and the device doesn`t power up, LED`s aren`t glowing on my camera or Joystick.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.