TechSpot

Problems Installing Saphire Radeon 9800 128meg Pro

By Psyle
Mar 14, 2005
  1. Everytime I plug my monitor into the back of my graphics card, nothing displays on the mointor and the light on it just starts blinking. The graphics card I was using was a GeForce 2 Integrated, and I uninstalled it then tried to install my Radeon 9800 Pro. I don't know if my AGP slot has to be turned on or anything, but if it does I do not know how to do it. I tried to download the drivers from www.ati.com and then it wouldn't let me install them because it said I didn't have a device that required them.

    My Specs:
    AMD Athlon XP 2000+
    1.7 GHz
    512 RAM
    Windows XP Pro SP 2
     
  2. BringinHeat

    BringinHeat TS Rookie Posts: 139

    Thats strange did you try going into the bios of your motherboard and setting up your display priority as agp try that and see if it works?? :wave:
     
  3. Psyle

    Psyle TS Rookie Topic Starter

    Thanks now it sees the graphics card, but i've got yet another problem! When I download the drivers from the ATI website and restart right after I see the windows XP screen, the screen goes black and stays black. However when I download the drivers from Microsoft Update, I restart fine, but they are older and they do not work well with World of Warcraft. Any suggestions?
     
  4. BringinHeat

    BringinHeat TS Rookie Posts: 139

    go to guru3d.com if the newest drivers from ATI are not working then try the drivers before that. The website above has an archive of drivers and you should be able to get a driver to workout for you. You didnt mention your power supply just out of curiosity how much power does your power supply generate??
     
  5. tbrunt3

    tbrunt3 TS Rookie Posts: 313

    What motherboard do you have? You will probbly need to install VGRAT drivers first the the card to work.
     
  6. Psyle

    Psyle TS Rookie Topic Starter

  7. tbrunt3

    tbrunt3 TS Rookie Posts: 313

    Sorry it is smartgart not vgart smargart on ATI web site or do a serch for them..Which is also on your motherboard chipset drivers..
     
  8. Psyle

    Psyle TS Rookie Topic Starter

    Well, I've tried a couple of those drivers on guru3d.com and a few things happened. I will install the driver and I will get to the point where i can see my dekstop and everything on it as it finishes loading, then the screen goes blank and eventually leads into a restart. Another instance is when I download the latest driver I will get right passed the windows xp screen and get into the log in area, and then it will go blank right after I click my profile and restart. Or it will also just go blank right after the Windows XP screen and yet again, restart. No idea why I can not use any of the drivers, this graphics card worked previsouly on my dell, which is a pos ;) . Any help would be appreciated.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...