TechSpot

Problems sharing AT&T Wireless Internet over Linksys Wireless Router

By helpleeze
Oct 2, 2007
  1. I have a Sierra Wireless Internet Card (USB) that is connected to my desktop computer. I also have a wireless network setup, and working, in my home with a Linksys WRT54G Router. The network works perfectly with respect to connecting my computers (Dell Desktop - wired & Mac Laptop - wireless) and sharing files. The internet works perfectly on the desktop computer where it is plugged in and I have designated the internet connection as shared but for some reason the Mac Laptop cannot access the internet connection through the wireless router.

    I had previously set the network up with a DSL modem that was plugged directly into the router but I cannot do that this time as the AirCard is USB only. I also, eons ago, had the same type of network setup with dialup to the desktop computer and was able to share that. I've set it up exactly the same but no luck.

    Could someone tell me what I am doing wrong? Thanks!
     
  2. jobeard

    jobeard TS Ambassador Posts: 13,474   +329

    oops; whenever you have a router, you do not SHARE the internet connection;
    each computer is configured as a DIRECT CONNECTION.
     
  3. helpleeze

    helpleeze TS Rookie Topic Starter

    The fix is??? I'm confused...

    Okay...

    What do I need to do then? I ran the network setup wizard and selected the option that says this computer (desktop) connects directly to the internet and other computers connect to the internet through this computer. And the result is a shared connection. I'm confused because that is exactly what I want to do. I have the internet connected diretly to the desktop via a USB AirCard and then the desktop computer connected to the router. As I stated before, I cannot directly uplink the internet connection to the router because it is a USB AirCard from AT&T.
     
  4. jobeard

    jobeard TS Ambassador Posts: 13,474   +329

    setting ICS says you're wire
    Code:
    modem--router-systemA---systemB
    and system A needs two NIC cards and systemB requires systemA to be active too

    with a router you should wire it up like this
    Code:
    modem--router ---systemA
             +
             +--------- systemB
    
    both systems will see each other AND have independent access to the Internet
    ie: one does not require the other to be running.

    edit:
    in your case; systemB is a wireless connection so use the Wireless Config Wizard
     
  5. helpleeze

    helpleeze TS Rookie Topic Starter

    Modem Can't Go To Router

    First let me thank you again for your help.

    I understand what you are saying and that is how I've always set up my systems before but I cannot hook the "modem" up to the router. It isn't a modem. It is a wireless air card that plugs into the USB slot on my desktop computer. This is what it looks like...

    http://www.wireless.att.com/cell-ph...=Sierra Wireless Aircard 875u&q_sku=sku950040

    It works off of cellular service not DSL or Cable. There is no ethernet output for me to plug it into the router. There is not external power, it is powered by USB.

    That said, the only way must be to share it on the network through the desktop and not directly through the router. Any ideas?
     
  6. jobeard

    jobeard TS Ambassador Posts: 13,474   +329

    AH! With the Mac/Cell setup, you have too independent networks
    Code:
    ISP-1   modem--router ---systemA
    
    ISP-2  ---/--- cellular access---Mac
    
    Each has an ISP at the other end and there are several issues for you:
    1. public addresss for both setups can change via release/renew
    2. the router has NAT to hide the systemA
    3. and all systems have firewalls to be configured
    4. and finally, your routing tables needs special care

    Sorry to say, I don't think this will work for you. Return the Celluar device
    and get a WiFi card for the Mac. Update the router to have the WiFi feature
    and then you can get back to the previous wiring shown above.
     
  7. helpleeze

    helpleeze TS Rookie Topic Starter

    There is NO MODEM. The internet is coming from the AirCard. I am not accessing WiFi. There is nothing I can plug into the router.

    Never mind. I'll ask my IT department at work.

    Thanks Anyways. :)
     
  8. Brothers

    Brothers TS Rookie

    Hello All!!

    I have a similar problem, i am using my t mobile dash to get internet access, and it only connects through usb. Did your IT dept help you out at all?
     
  9. helpleeze

    helpleeze TS Rookie Topic Starter

    IT Help

    I was told that internet connection sharing should have done the trick and that my problem was most likely between the MAC and PC interface. That it was being finiky and that I should call my cell phone provider for help. I haven't done that yet but have contacted them with similar questions before and they've been very helpful. I'm optimistic. Good Luck!
     
  10. jobeard

    jobeard TS Ambassador Posts: 13,474   +329

  11. tigsounds

    tigsounds TS Rookie

    Try this...

    Joebeard is trying to be helpful and means well but I disagree that internet connection sharing needs to be turned off on the computer making the internet connection, here's why..

    This is the machine of internet source for all other machines. Internet connection sharing *must* be turned on for the computer to make the internet available to the Ethernet port distributing the internet connection to the router. You will need to use a crossover cable to connect the router to this computer and plug this cable into the "internet" connection at the router. This will allow the router's DHCP function to distribute the internet to the other computers connected to the router (including wireless). If you do not have a crossover cable, the host computer must be plugged into any of the regular ports on the router, however, port #1 is preferred. This is less efficient, but can work. One more place that can stop a router connection is the IP address of the computer towards the router. The "Local area connection" used should be set to obtain an IP address automatically, or be set up with a *valid* static IP address with the router.

    Windows Firewall can cause trouble with internet connection sharing.
    Go to control panel, select Windows Firewall. Click the "Advanced" tab and then click (checkmark) the shared connection you will be using. Now click "settings" button adjacent to the box you just made the check in. In the "Services" tab, mark/check *everything*, now click the "IMCP" tab and again, mark/check *everything*. Now click "ok", check all connections from computer to router etc, restart computer and check host computer actually can access the internet, if ok, check LAN port lights (if available) showing a connection is in fact made to router, check router status lights also. Wait about 3-5 minutes before attempting to access internet on other computers connected to the router. This gives Windows time to complete all negotiations with router.

    If host computer can access router, all computers connected to router should be able to access internet. Open browser, go to site 192.168.1.1 and router log-on page should be showing, if it is not, then here you have a connectivity problem with the router. If you are able to connect to the router and other computers still cannot connect, the problem is internet connection sharing on the host machine. Turn off Windows firewall and try again, make sure sharing is turned on for the port that actually brings in the internet to the computer. All this said, it should work, as long as you have ran the network setup wizard and configured your computer to be a proper internet host... but that is something I'm going to assume you have already done.
     
     
  12. jobeard

    jobeard TS Ambassador Posts: 13,474   +329

    Windows Services overloads support and complicates the setup.

    ICS is sometimes necessary, but print/file sharing is never a requisite to getting internet access.
    PF/S needs ports 139,445 to be open and if the gateway system
    (that which has the connection to the ISP) allows uncontrolled PF/S, you can kiss your
    personal data good bye.

    The windows firewall is terrible at this level. Several third party firewalls will allow you
    to specify PF/S access ONLY from local lan addresses and block public addresses.
    The sole caveat is a laptop at a hotspot, where all access is via a local lan address.
    In this case, you *must* change the firewall rule from allow to deny to protect your
    file shares.

    In general, ICS is (imo) a choice of last resort and the use of a router is a better choice and leads to more satisfaction.
    Of course there are special cases, such as a traveling laptop and any connection is better than none at all.
     
  13. tigsounds

    tigsounds TS Rookie

    Quoting jobeard...

    "In general, ICS is (imo) a choice of last resort and the use of a router is a better choice and leads to more satisfaction.
    Of course there are special cases, such as a traveling laptop and any connection is better than none at all. "


    I absolutely agree. helpleeze has a USB internet connection so is stuck with what Windows will do in this situation.

    The best solution for helpleeze now is to purchase a Kyocera KR2 Mobile Router and kiss all internet sharing troubles goodbye. This is a really cool router as it accepts so many different card types and is compatible with so many different IP's.
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.