TechSpot

Problems sharing files on local network

By killiank
Jan 1, 2006
Topic Status:
Not open for further replies.
  1. Hi all!

    I have a local home network of 3 computers via a linksys cable router. They are computers A, B, and C. They all are running Win XP Pro. I have been successfully gaming with all three computers before and able to access files from each other. However, I have recently had a problem accessing files on computer A from B or C. A can access shared files from B or C just fine. B or C can ping A by both IP address and name, but if B or C does a Net View of A the result comes back as Access is Denied. Net Send is able to send a message to computer A just fine.

    I have checked time and again that computer A is sharing files out to the network and that the windows firewall is not enabled. Any suggestions?
  2. Gandalph

    Gandalph TS Rookie Posts: 34

    Check to make sure that both folder permissions and NTFS permissions (under the security tab) are set to Everyone with at least Read permission.
  3. killiank

    killiank TS Rookie Topic Starter

    I have double checked that all permissions are given; still no access. Another stange thing to note is that the computer only has one NIC card (in slot 2) but in the device manager it has two adapters. One says it is in slot 2 and one says it is in slot 3. Both adapters are the same but the second one is titled with a #2 at the end. I keep trying to remove it and it gets put right back. I have tried to run virus protections and anti-spy ware with nothing found. Any other suggestions?
  4. Gandalph

    Gandalph TS Rookie Posts: 34

    Because you are getting "Access Denied" error message, I have to think it is a permissions issue. It may have been set in local security policy, share permissions, or NTFS security permissions, but the Access Denied message indicates that it is definitely permissions related.
  5. jobeard

    jobeard TS Ambassador Posts: 13,403   +313

    the machine which can not be access, go to the Windows Fireall and enable
    Exceptions -> File/Print Sharing

    If you're using some eom firewall,
    allow i/o ports 139,445 tcp+upd for your LAN addresses only
  6. SCHUMIinSA

    SCHUMIinSA TS Rookie Posts: 162

    I know this would be a labour-intensive task, but why not try and setup the network all over again from scratch? Also be aware that certain files can't be shared. I am not sure which, but some reasons when I tried to copy folders over a network they sometimes fail to copy because of one silly little file somewhere in the folder. Folders which contain processes currently running can't be copied. Windows and Program Files can't be copied. Have you enabled sharing on C: or whatever drive you main-hardrive is? If you did not then access will be denied.
    That's about all I know about Networks so far, sory if it's not much help but I am fairly new to Networks.
  7. killiank

    killiank TS Rookie Topic Starter

    Gandalf,

    I am under the impression that it is a permissions issue too. It is my son's computer. I am not sure if he or his friends loaded something on it or not; not that I can tell. It is running XP professional in a Work group. The C: drive is in NTFS Format but I don't get a security tab on the properties, only a share tab. It has to be the way I have them configured because it is all my machines not just the one in question. Any idea how I check this out? Also, I know nothing of configuring security policies; any help there?
  8. killiank

    killiank TS Rookie Topic Starter

    I am not using a firewall. I have made sure that even the Windows firewall is turned off to prevent any problems with sharing files accross my workgroup computers. I have a firewall at my router before going out to the internet.
  9. killiank

    killiank TS Rookie Topic Starter

    SHUMIinSA,

    Thanks for the comment. I have shared the c: drive out. On other computers even If access is denied, I can see the drives; not on this machine.
  10. Gandalph

    Gandalph TS Rookie Posts: 34

    In Windows Explorer, click on Tools, then Folder Options. On the next window, click on the View tab, then in the bottom sectiom (Advanced Settings) scroll all the way to the bottom and uncheck "Use Simple File Sharing". Once this is done, when you select properties on a share, you will have a security tab and can then view and/or change your NTFS security. Do this on My Computer and make sure that Everyone has at least Read and Execute permission.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.