TechSpot

Problems with newegg.com?

By MetalX
Oct 26, 2006
  1. Is anyone else having trouble loading www.newegg.com? Whenever anyone posts links to newegg for product suggestions etc. The page never loads for me. It just keeps saying "loading" indefinately. I have tried loading it in Firefox and IE. Newegg doesnt even work if i just type www.newegg.com and try to get to the main page... anyone know whats wrong?
     
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    This is only a suggestion.

    Do you have anything that Blocks HTTP Sites Installed, such as Peer Guardian? It'll block all access to HTTP Sites if the Option Is enabled.

    Regards Howard :)
     
  3. MetalX

    MetalX TechSpot Chancellor Topic Starter Posts: 1,388

    I don't think so because every other http site works, such as this one... (this is an http site right? I see the "http://" at the top)
     
  4. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Sorry, that was something I found via Google that helped someone else with the same problem as you.

    I`m afraid I have no further ideas.

    Regards Howard :)
     
  5. wolfram

    wolfram TechSpot Paladin Posts: 1,967   +9

    Are u using broadband internet? Or dial up?

    Any firewall software like ZoneAlarm?
     
  6. MetalX

    MetalX TechSpot Chancellor Topic Starter Posts: 1,388

    No firewalls, 2megabit broadband... and newegg doesn't work. Maybe THEY blocked ME.. lol.
     
  7. wolfram

    wolfram TechSpot Paladin Posts: 1,967   +9

    Bad luck I guess.

    BTW, you should install a firewall, unless you want to get trojans, dialers, or some **** like that. ZoneAlarm Free firewall is pretty good.

    And do you have SP2? It has a built-in firewall. Probably that's blocking you, but I'm not sure.
     
  8. mailpup

    mailpup TS Special Forces Posts: 6,979   +362

    FWIW, I haven't had any site loading problems with Newegg recently. In fact, I ordered a few items yesterday, the day of your first post. They are scheduled to be delivered today! :)
     
  9. MetalX

    MetalX TechSpot Chancellor Topic Starter Posts: 1,388

    Ok, well it worked for a few days, but now its back to the old standby. I can't figure out why its not working :( I do use windows firewall but i tried disabling it and that didn't help.
     
  10. N3051M

    N3051M TS Evangelist Posts: 2,115

    go to Tools>internet options
    -Clear cache
    -clear cookies
    -clear temp internet files

    That should get you in.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...