Problems with YouTube and Flash

By mugen
Oct 24, 2007
  1. Hi everyone,

    When I wanted to watch some videos on YouTube, It came up with saying that I need to update my Flash player because my Flash player is too old...however, when I updated my Flash player, i still couldn't see the videos...I looked to youtube troubleshooting guide and i did the following:

    1. Delete the current existing Flash
    2. Restart the computer
    3. Re-install the Flash

    when i go to YouTube, i still couldn't see watch any videos..and i checked and disabled my firewall...but the flash video still not showed up..i tried using every browser: IE, Opera, Mozilla and none of them can play videos from YouTube with the same problems that my flash player is too old...but i updated it already! I also updated my Java, Shockwave, etc etc and it didn't solve the problem...

    Anyone has any idea what is going on?
  2. Po`Girl

    Po`Girl TS Rookie Posts: 595

    You can find Adobe`s own comprehensive troubleshooter HERE

    Apart from the obvious things it mentions pop up blockers,
    restricted user acounts, active x issues.
  3. Route44

    Route44 TechSpot Ambassador Posts: 11,966   +70

    If you are using the lastest Flash offering from Adobe then join the many of us experiencing issues. It affects people in different ways. In my case it will suddenly cause IE to shut down. Microsoft reports that this is Adobe's issue, they know about it, but have yet to fix it.

    Po 'Girl, thanks for the link.
  4. SNGX1275

    SNGX1275 TS Forces Special Posts: 10,689   +395

    I didn't have anything constructive to add when I first saw this thread, but now that there are a couple replies I will.

    I had this problem with Opera 9.5 Alpha on OS X (10.4.10) where a youtube video linked from would play, fark now has youtube videos embedded. Then that same video on youtube wouldn't play, I'd get an error saying I needed new flash. I didn't think much of it at the time because I'm running an Alpha release browser, and its Opera (which sometimes doesn't play well with flash), and it was on a Mac. But then, someone on fark had the exact same complaint, and they were using Firefox I think, on an XP machine.

    Basically I don't know whats wrong, but you aren't alone in having problems.
  5. mugen

    mugen TS Rookie Topic Starter

    Thank you for everyone's support on this matter. I will keep inform about anything new on this matter

    Po`Girl thanks for the the link
  6. cuyo2005

    cuyo2005 TS Rookie

    here is the solution

    hi guys, i was crazy trying to fix this, and i finally did so i want to share it with you, all you have to do is download the standalone installer,after installation completes all you have to do is restart internet explorer (you don't even need to restart the pc) and youtube will work fine!!!!
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...