Program starts invisibly.

By Reavance
Nov 4, 2007
  1. A friend of mine is having issues with programs starting invisibly.
    One program in particular would be Hammer, the map editor for HL2.
    There will be an instance of the program in task manager but it isn't actually accessible. The same issue is occurring with a program on a flashdrive that has proven to work on another PC.

    Any help would be greatly appreciated.
  2. Ididmyc600

    Ididmyc600 TechSpot Chancellor Posts: 1,415


    all programs that start at loadup are usually found in

    Start run msconfig startup.

    Or in the startup folder on the start menu.

    Or in the registry, but i wouldnt go in there unless you need to.

  3. Reavance

    Reavance TS Rookie Topic Starter

    It isn't starting at Start-Up, it's starting when clicked on, the trouble is that the program isn't supposed to be a background program and has a GUI that isn't accessible. The fact that it's occurring on multiple programs and that we've done everything I can think of to verify the integrity of this program suggests to me that it is a system issue and not one with program itself.
  4. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    If it shows in the Task Manager, then it's running in the background and likely started on boot The only "invisible" programs I know of would be from spyware, adware, viruses, Trojan or worms..

    "It isn't starting at Start-Up, it's starting when clicked on, " So where did you click on it?

    I don't know what you mean by saying it isn't accessible. Where are you trying to "access" it from
  5. Reavance

    Reavance TS Rookie Topic Starter

    Perhaps I've been vague.
    The program is called Hammer.
    It does not start at Startup.
    It's a program that we want running.
    The program normally has an application window and appears on the task bar.

    Here's the problem
    The program does not open an application window when it starts and does not appear on the task bar. We know it is running because the process is present in task manager.

    The program has been uninstalled and reinstalled and the files verified.
  6. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

  7. Reavance

    Reavance TS Rookie Topic Starter

    That thread has nothing to do whatsoever with the issue that is occurring.
  8. ChrisLam

    ChrisLam TS Rookie Posts: 82

    I think what Reavance is trying to get at is that when he wants Hammer to start, the process starts but there is no GUI or anything. The only proof that it is running is the process, nothing else.
    Is this right Reavance? Is the program buggy and needs to be updated to a newer version or something?

  9. Bobbye

    Bobbye Helper on the Fringe Posts: 16,335   +36

    Then perhaps I'm not clear on this issue. Perhaps you could make it clearer?

    I'm just amazed at the rudess of some here. All volunteers on any board try to find resolutions for problems presented. We don't always get all the information we need or is isn't clearly presented.

    Maybe you could have said something like "thanks, but that doesn't work for my problem"?
  10. Reavance

    Reavance TS Rookie Topic Starter

    That is exactly the issue. But it doesn't seem like a program bug as it works on my computer and has previously worked on my friend's.
    I've tried the relevant support information for the program and can't find any accounts or fixes for this or similar issues.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...