PSU or GPU or Mobo issues with booting

By Kona61
May 26, 2014
Post New Reply
  1. Computer:
    Mother Board: Asus p8z77
    Processor: Intel i7
    GPU: MSi GTX 660 Twin Frozr
    PSU: Corsair cx750
    RAM: 2x2gb Crucial Sticks

    Hello, I'm new here! Anyways I tried installing new RAM to my custom desktop, however I installed just one Crucial 2gb stick because I couldn't find the other stick. When I tried starting the computer it made a single pop and shut down. Soon afterwards, I smelt a burning smell. I immediately took out the RAM and tried starting. The computer turned on for about 3-5 sec then it shut down. I tried pushing the button but the computer wouldn't start. I tried turning the power supply off then on and the computer started. However, the computer won't show any picture and the screen says no signal detected. The mouse and keyboard also won't work. I have tried resetting BIOS by taking battery out for 10 min and holding power button while disconnecting. I also checked the old RAM for burns or signs of damage. Now the computer is unreliable and only sometimes even turns on. Sometimes it does a quick turn on then off or it won't work at all. I also checked the graphics card for signs of damage and I took it out,too. So if I can get help with this issue I can't solve, thanks in advance :)
  2. Cobalt006

    Cobalt006 TS Evangelist Posts: 1,777   +241

    Your motherboard is bad.
  3. Kona61

    Kona61 TS Rookie Topic Starter

    So you're absolutely sure that's what the problem is?
  4. Cobalt006

    Cobalt006 TS Evangelist Posts: 1,777   +241

    Sounds like when you installed the ram. You might have cause some static from your self. In turn shorted the motherboard. No I can not say for sure. The only other thing is maybe the PSU is bad. You try other one and see . Either way something has shorted out. From what you posted it dose not sound good.
  5. Kona61

    Kona61 TS Rookie Topic Starter

    I may have accidentally usedstatic because I forgot to use my grounding bracelet with the alligator clip and ive already ordered a psu a corvair cx850.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...