PSU Problem

By spartanslayer
Feb 14, 2007
Topic Status:
Not open for further replies.
  1. Hey Guys, been a while since I posted.
    I've got a problem with my PSU. Here's the deal.
    First the disclamers. I've had it for 7 months and put full strain on it many times, never had a problem before.

    About four days ago, my computer started locking up. It would freeze for 5 seconds and then resume. Three days ago, I started hearing a noise coming out of my comp. It sounded like a hissing/static/crackling. I kept having the weird problems too. Yesterday, my computer lock up a lot more than before. And today, my mouse isn't responding. I logged on and tried to use several different mice, none of which worked. Do you guys think the problem could be the PSU. I did confirm the noise is coming from the PSU, not anything else. Couldn't identify where in the PSU it came from. I would appreciate any help.
    Sincerely,
    Spartanslayer.
  2. howard_hopkinso

    howard_hopkinso Newcomer, in training Posts: 25,948   +17

    Nice to see you around again spartanslayer.

    I agree, it does sound like a psu issue. try another psu and see if your problems go away.

    I certainly don`t advise waiting till it goes altogether, as it may take other components with it.

    Regards Howard :)
  3. spartanslayer

    spartanslayer Newcomer, in training Topic Starter Posts: 464

    Yeah, I haven't been using it, don't want to fry the Vid Card! Thanks for the quick reply. I will try a new PSU on Sat, just wanted some advice in the meantime.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.