TechSpot

PSU underpowered?

By doktaluv
Jan 14, 2007
  1. Hi all, I've been trying to sort out this video card issue for quite a while. I've got it down to the point where it won't BSoD as frequently, but it's still causing some issues which are annoying the heck out of me.

    I've got an ASUS A8N-SLI Premium w/ an AMD Athlon 64 4000+, 2GB of Ultra PC3200 400MhZ DDR RAM and a BFG Tech GeForce 7950 GT. I'm getting the IRQ and PAGE FAULT errors, though not as frequently -- I've updated the latest drivers. What I'm wondering now is related to my PSU: I've got an Ultra V-Series 400Watt ATX Power Supply. It's only got 20amps to the +12V rail. Not enough? Upon monitoring the voltage levels I'm only getting 11.84V to the 12V rail. The only other item connected to my PC currently is a DVD-ROM.

    Usually I don't BSoD, it just locks up mid-game. I purchased this PSU packaged with my case and was unsure as to whether it was beefy enough, but figured I'd give it a try and find out.
     
  2. mailpup

    mailpup TS Special Forces Posts: 6,979   +362

    According to BFG's website, the 7950 GT requires a minimum of a 350W power supply with 22 amps on the 12V rail. It appears yours doesn't have enough.
     
  3. doktaluv

    doktaluv TS Rookie Topic Starter Posts: 32

    Muchos gracias mailpup! I keep trying to dig around on their website but get absolutely nowhere. I've called their tech support but the guy on the line keeps telling me it's perfectly fine. :evil: That or tries to sell me a 650Watt+ power supply. Techies don't make good sales folk in my opinion :haha:

    Methinks I'll have to go root around and see if I can find a decent power supply locally -- I don't particularly want to wait for shipping as I'm giddy over this new system. Thanks a bunch!
     
  4. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    PSUs never deliver their listed wattage. They lose a lot of power from heat loss.
    If you require 350W of power, buy a minimum of 450W. Also PSUs lose power over time due to capacitor aging. a 2 year old PSU will lose about 30% efficiency if run all the time.
     
  5. doktaluv

    doktaluv TS Rookie Topic Starter Posts: 32

    Yeah, I figured that it wouldn't deliver the proper wattage. I know it's a big rant from everyone to constantly hear new folks whine about errors related to their power supplies and to everyone: sorry! :haha:

    I bought this one via tigerdirect in a package with the case. 'Twas cheaper than purchasing them separately, though it looks like I would have saved money had I bought another case package with a better power supply. Ah well.

    EDIT: Do you folks think this is the specific cause for my BSoD's? nv4_disp.dll throws fits whenever I attempt to increase any settings, etc. etc. The temps remain pretty stable, so this is really what I've narrowed it down to...
     
  6. doktaluv

    doktaluv TS Rookie Topic Starter Posts: 32

    Okay, I just bought an Antec SP-500 with 2 12V rails of 17amps and 19amps, bringing the total amperage up to 36amps. Hopefully this will cure my problems!

    Will run memtest again tonight to see if it does anything screwy. The A8N-SLIs are apparently really picky about memory.... :sigh:
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...