TechSpot

PSU's fan doesnt work.

By thetringuyen
Mar 6, 2007
  1. hi all, I got a problem with my psu.. PSU fan doesnt work O.o... here wut i have
    PSU: Antec TruePower Trio 650W
    Mainboard: INTEL BLKD101GGCL XPRESS200 775
    CPU: INTEL|P4 650 3.4G LGA775 2M 90NM
    VGA EVGA 7600GT 256-P2-N615-TX (PCI express)
    Ram: 1 Kingston 1GB PC3200 CL3 184pin DIMM DRR + 1 Ultra 512Mb PC3200 CL3 184pin DIMM DRR
    1 HDD 120GB seagate
    1Samsung DVD+- RW
    .. and the big fan in the PSU doesnt work, the PSU is super hot now O.o I have to put an extra fan next to it to cool it down while trying to figure out why.. .. help plz.. thx
     
  2. be_patient

    be_patient TS Rookie Posts: 105

    buy a new psu!
     
  3. thetringuyen

    thetringuyen TS Rookie Topic Starter Posts: 22

    that a new one.. just bought lik month ago:( it worked fine.. but then i just got new mainboard+cpu + graphic card n it doesnt run anymore..
     
  4. dmill89

    dmill89 TS Guru Posts: 737

    If you can, return it where you bought it and get a replacement. If it's been too long send it into antec for repair/replacement (it may take up to a month) under warenty (it has a 3 year warenty).

    You could open it up and replace the fan with any 120mm fan (requires soldering) you like But this would void your warenty and you could get shocked if you don't know what your doing.
     
  5. thetringuyen

    thetringuyen TS Rookie Topic Starter Posts: 22

    yeah... i bought this from bestbuy.. the date for return has passed.. do you know if they would let me have a replacement? I dont want to send to the manufactor.. cuz then i will not have a psu to use for month.. :(
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.