radeon 9200 series Graphics Card Problem

By denn
Dec 17, 2005
  1. Can any one help
    This has got to the stage where I am going to dicard this card,
    Its a radeon 9200 series 128mb,
    I have contacted the manufacturer with no success, downloaded all the up to date drivers, changed my monitor settings .. the list continues
    the problem is when I play games , Doom half Life Medal of Honour, ( by the way the PC is a 1.6 Ghz with 500 + of ram these games worked fine on Win 2000 but on XP there`s a problem) this being that the graphics flicker and you can see behind certain images, not explained very well I know but the images flicker on and off in like triangle blocks so if you looking at say a wall , the wall is there but it flickers to black triangles.. if anyone can understand waht I`m saying maybe they could advise
  2. Federelli

    Federelli TS Rookie Posts: 361

    I'm asuming you have Cats 5.12.
    Does the card have a heatsink and a fan? If it does, is the fan working correctly?

    If it is, then you've got a bugged GPU, see if you can get it replaced.
  3. denn

    denn TS Rookie Topic Starter

    has a heatsink but no fan
    Bugged GPU .. I assume you mean its Knackered
  4. Federelli

    Federelli TS Rookie Posts: 361

    It's either overheating, or it's as you said.
  5. jaroddog

    jaroddog TS Rookie Posts: 87

    Hah! Knackered! I like that. Don't throw that beast away. Not yet. It could be a system problem. But there is probably some poor sap on here who would love to try to figure it out. Maybe like me. :D Seriously, how's your system stability with with Windows XP. A lot of errors will show up under Windows XP that wouldn't under, say, Windows 98SE.
  6. denn

    denn TS Rookie Topic Starter

    stability on XP and all other Windows is OK
    the problem is just with the games only
  7. Flipi

    Flipi TS Rookie

    Try opening the case and have a blower cool the card. If the problem persists then the card is faulty - not sure wether the Gpu or the memory...
  8. Rage_3K_Moiz

    Rage_3K_Moiz Sith Lord Posts: 5,431   +28

    Hey this problem used to be there for one of my friends too. He had a Jetway Radeon 9200SE and this problem used to be there for him in Doom 3 too. But he says it only started from him after he first exited Hell. And it was only in Doom 3. Half Life 2 worked fine for him. Just so u would know.....
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...