TechSpot

Ram upgrade problems

By totohobo
Sep 12, 2008
  1. with 4 x 512 kingston ddr2 ( 667 ) blue screen appear only after safe mode says :

    The bios in this system is not fully ACPI compliant. Please contact your system vendor for an updated bios. If you are unable to obtain an updated bios or the latest bios supplied by your vendor is not ACPI compliant, you can turn off ACPI mode during text mode setup. To do this, simply press the F7 key when you are prompted to install storage drivers. The system will not notify you that the F7 key was pressed - it will silently disable ACPI and allow you to continue your installation."

    bios ver is F6 latest for my motherboard now windows xp won't boot all rams are same brand same bus and won't load windows can't access bios .
    the pc work fine with only 2 x 512 kingston ddr2 ( 667 ) the board had 4 banks so can anyone help me with this problem ???

    my pc specs :

    MB : GA-945P-S3(rev. 1.0)
    --------------------------
    BIOS Ver : F6
    -------------------------------------------------------------------------------
    VGA Brand : powercolor Model : x1550
    CPU Brand : Intel Model : core 2 duo 4400 Speed : 2gb
    Operation System : Win XP SP : 3
    Memory Brand : Kingston Type : DDRII
    Memory Size : 2x512 Speed : 667
    Power Supply : 300 W

    thanks in advanced
     
  2. fastco

    fastco TS Booster Posts: 1,122

    You need to install 2x 2GB memory modules in two of the memory slots. Some motherboards use slots 1&2 others use 1&3 etc... just put one memory module in each of the two slots that are the same color.
    HERE is the link for the manual if you need it.
     
  3. totohobo

    totohobo TS Rookie Topic Starter

    thanks for your fast reply

    i have 4x 512 rams all the same and motherboard support up to 4gb of ram so why i can't use all the banks at the same time my ram brand is kingston KVR667D2N5/512 and motherboard support it but in the Memory Support List says SS single side so i can't use all 4 rams at the same time i wonder ???
     
  4. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

  5. fastco

    fastco TS Booster Posts: 1,122

    That's what I'm saying.
     
  6. porsche911r

    porsche911r TS Rookie Posts: 37

    fastco i think what they are saying is that the dual channel normally works with banks 1 and 2 and then 3 and 4 but i think this setup maybe different in ur mobo so just trying changeing this and it may help.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...