Realtek AC97 Microphone Problems

By RealtekAc97
May 29, 2006
  1. I have the realtek ac97 with build in 5.1 audio and about a week ago I started to get a weird thing happening with my mic. Now i've already determined the problem is not the mic. But what happens is when I talk there is about 1.5 seconds of distortion then 1 second of no distortion and it just keep repeating like that. People say it sounds like I have a fan right up against the mic. Needless to say when i'm talking no one can understand me and i'm in a gaming clan so it's crucial to my success that I can talk. Anybody know what the problem is or what I can do to fix it?
  2. wolfram

    wolfram TechSpot Paladin Posts: 1,967   +9

    Do you have the latest drivers from Realtek?

    Also, distortion in audio could be caused by the internet connection. It can sound sometimes funny, like an alien sometimes. :dead: :unch:

    Have you tried recording your voice in Windows using the sound recorders?
    Try that, and if your voice sounds fine, then it´s an internet problem.

    Good luck! :wave:
  3. RealtekAc97

    RealtekAc97 TS Rookie Topic Starter

    i've tried though and for some reason my webcam which I can record video and voice with I record and click stop and usually it open up after that but it doesn't anymore!
  4. wolfram

    wolfram TechSpot Paladin Posts: 1,967   +9

    Can you give us some system specs?
    And try the new driver, it could help.

    Good luck!
  5. RealtekAc97

    RealtekAc97 TS Rookie Topic Starter

    I installed a new driver and it helped a little but it didn't really do much it's still hard to understand me but atleast it's not pulsating distortion now.
    AMD 3500+
    2.21 Ghz
    1 GB ram
    NVidia Geforce 6600
    WIN XP
    Realtek mother board with onboard 5.1
    anything i'm missing?
  6. wolfram

    wolfram TechSpot Paladin Posts: 1,967   +9

    The motherboard model.

    Also, what´s the distortion after the new driver?
  7. RealtekAc97

    RealtekAc97 TS Rookie Topic Starter

    (Sckt939)EVGA nForce4 SLI Chipset SATA RAID Dual PCI-E Mainboard w/GbLAN,USB2.0,&7.1Audio I think this is the one. Well the level of the distortion dropped a bunch but I can still hear it a little bit it's low and my voice is still crackly. As for my connection I have comcast broadband so I doubt the connection is causing a problem.
  8. wolfram

    wolfram TechSpot Paladin Posts: 1,967   +9

    Why don´t you try another mic and see if that solves the problem?
  9. RealtekAc97

    RealtekAc97 TS Rookie Topic Starter

    already did tried my brothers no change
  10. kirock

    kirock TS Rookie Posts: 1,221

    Can you plug it into another connector (let say the back one), not the front connector, to see if it's at fault? If it is the front connector, then check your mobo plug, maybe it's loose.

    Also check your AUX control panel and make sure your mic input level is not turned way down and you haven't set some funky special effect on accidently.

  11. wolfram

    wolfram TechSpot Paladin Posts: 1,967   +9

    Keep on mind that some, (but not too much) distortion should be allowed. Integrated sound cards don´t have the same audio quality as a Sound Blaster Audigy for example.

    Is the distortion VERY annoying?
  12. commandle

    commandle TS Rookie

    yea im having the same problem, and ppl mute me on games.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...