TechSpot

realtek ac97 sound only from 1 speaker

By robsherriff
Feb 21, 2007
Topic Status:
Not open for further replies.
  1. hi everyone

    I've got a realtek ac97 sound card. sometimes it works fine for days but then it will only produce sound from 1 speaker for days. I've reinstall the latest drivers and codecs. and its not the speakers or wires as I've tried them with other equipment. please can any one help!!!
  2. Bluemouse

    Bluemouse TS Rookie Posts: 405

    Are you running vista?
  3. robsherriff

    robsherriff TS Rookie Topic Starter

    sorry forgot to say. no im on xp sp2.
  4. Ruben

    Ruben TS Rookie Posts: 105

    start PC in safe mode, uninstall realtek drivers, reboot into normal mode, run regcleaner or similar app, install drivers for your realtek audio.
    Make sure you are installing the correct ones.
    Is that desktop or laptop? If nothing works it could be the jack itself - in this case dedicated sound card (PCI or USB) would be the option. They are cheap these days. Good Luck
  5. ggrape1

    ggrape1 TS Rookie

    I have got the same trouble, tried different speakers and reinstalled drivers. Dont know if it is the jack as it happens also with the earphones jack. It seems to me its either a software or hardware problem but I would like to know as I have seen many with this kind of trouble over the Internet. computer emachine and intel motherboard with built in one. Any info or advice appreciated before going to buy a new sound card because all my slots are already taken. Thanks
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.