TechSpot

Red Faction Problemz!

By skitzo_zac
Jul 22, 2007
  1. I installed Red Faction the other day thought I replay the game cos its a classic(IMO that is). And well its kinda a bit screwed up. It looks like this
    Anyone know how to resolve this issue? because I would enjoy playing through the game again.
     
  2. mailpup

    mailpup TS Special Forces Posts: 6,979   +362

    Try an updated graphics driver.
     
  3. skitzo_zac

    skitzo_zac TechSpot Chancellor Topic Starter Posts: 418

    I had forecware 158.22 and thats what that screenshot is using. and I upgraded to 162.18 (only a Beta) and it sill has the same wierdness going on with it.
     
  4. mailpup

    mailpup TS Special Forces Posts: 6,979   +362

    As best as I can tell Forceware 158.22 is for Server 2003 x64 or Windows XP x64. Do you have the 64 bit version of Windows XP?
     
  5. skitzo_zac

    skitzo_zac TechSpot Chancellor Topic Starter Posts: 418

  6. mailpup

    mailpup TS Special Forces Posts: 6,979   +362

    You're right. I made a mistake and looked at the 158.22 driver for the wrong Windows version. I thought you might have installed the wrong version but not so.

    The only other thing I can think of is maybe reinstalling the game with patches. I have this game too but I never had your problem.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...