TechSpot

Reinstalled Windows XP Pro - No ethernet

By MandyLea83
Apr 12, 2009
  1. I recently reinstalled Windows XP Pro but cannot get internet using my ethernet card (for some reason I can get wireless). When I connect directly to the modem it says I have "limited or no connectivity."

    I tried deleting and reinstalling the driver. I checked that it was assigning the IP address automatically. All sorts of things. Now I am browsing forums trying to figure out if anyone has any idea what is wrong and how to fix it.

    Let me know. I'd appreciate the help.

    Thanks.
     
  2. elfi

    elfi TS Rookie Posts: 68

    MandyLea you did uninstall and than reinstall the ethernet driver. does your OS see your ethernet after reinstalling the driver? did you try a repair on it? you could try winsockfix too i think. heres the link
    http://www.softpedia.com/get/Tweak/Network-Tweak/WinSockFix.shtml

    if reinstalling the right driver or fixing it doesn't help than maybe it's the hardware but lets not hope that
     
  3. MandyLea83

    MandyLea83 TS Rookie Topic Starter

    I appreciate the reply but I solved the problem. After working at the problem for days, I realized what was wrong. I was connecting directly to the modem, I did not have a router. I needed to reset the modem using a pen and pushing the tiny button in the back.

    Again, I appreciate the replies.
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...