TechSpot

Remote Desktop Connection Change of Port

By Phantasm66
Mar 7, 2002
Topic Status:
Not open for further replies.
  1. Here's a little gem I was told today.

    Trying to use your remote desktop connection over the internet, but having problems with ports being blocked (i.e. because of a firewall at work, trying to reach your home machine)???

    Then edit this section of the registry:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Terminal Server\WinStations\RDP-Tcp

    Find the portnumber value, and click decimal. Change it whatever you like (80 and 8080 are usually unblocked on firewalls for http access on remote web servers...)

    I didn't have to restart the service.

    This only works in XP professional or in Windows 2000 Server with the Terminal services installed.
  2. Whack0

    Whack0 TS Rookie Posts: 169

    ...Can you clarify what this 'gem' does again for me? :confused:
    Or is it something I don't need to worry about?
  3. Phantasm66

    Phantasm66 TS Rookie Topic Starter Posts: 6,504   +6

    Its a way of changing the port that the terminal server built into windows xp or installed on windows 2000 server operates on. If the port is blocked on your firewall (perhaps by a sys admin at work) then you get change the port to be the same port that http usually works on. That way you can open your desktop at home from work (or vice versa) and control one computer from the other, assuming you have a nice fast connection both at work and at home.
  4. TroyMac

    TroyMac TS Rookie

    To exlpain this properly.
    your workplace firewall may not allow port 3389 for outbound trafic, although this is ver doubtfull. Most places don't care if you go out with this port they just wont allow it in through the firewall.

    On your home PC in run RegEdit from Start Run.
    In regedit change the value to the key as expained above use 3390 or 9997
    the default is 3389 just incase you want to change it back. You can use 80 or 8080 if you like but that leaves you open to hackers. also the default leaves you open as well.
    After that when remote desktoping in run remote desk top with your IPaddress ie. xxx.xxx.xxx.xxx:3390 notice the colon and 3390 this is the port that you just change in the registry.
    I have had issues with this working on W2K so if it does not work you will have to set it back to 3389. This is great if you have more then one system at home, keeps you from having to piggy back remote desktops.
  5. Ktixx

    Ktixx TS Rookie

    Is there any way to change the port on the computer you are using MSTSC from so you wouldn't have to use a :XXXX?
    Ken
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.