TechSpot

Reoccuring Problem...

By Cephas
Jan 19, 2008
  1. Hi, this problem isn't too dangerous I don't think but it's getting pretty annoying...

    Every time I start up my account I get an "Active Desktop Recovery" screen with a few troubleshooting options and things...but the thing is I always have Active Desktop disabled and every time this happens I go to the settings and the active desktop tickbox isn't ticked.

    Also, probably relatedly, however many times I make the language bar dissapear, when I log in, it's there again...
     
  2. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Hi Partian Shot

    Also try removing your wallpaper, before restart
    There are also a number of programs that can be set for windows startup, that can enable web wallpapers (and active desktop)
    You could download Startup Control Panel and remove any unwanted startup link.

    In regards to the language bar.
    Is your user an Administrator account.
    Go to users in Control Panel to confirm.
     
  3. Cephas

    Cephas TS Rookie Topic Starter Posts: 78

    Well, there's no unwanted startup thingies... Plus active desktop always is disabled according to the tickbox...

    Did I mention the Active Desktop Recovery message goes simply when I change my wallpaper or check and uncheck the active destop tickbox
     
  4. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Remove your wallpaper fully to None (as stated above)

    Also, are you an Administrator account ? - not answered

    Did you use the Startup program, and look at all tabs ?
     
  5. Cephas

    Cephas TS Rookie Topic Starter Posts: 78

    1. I want to keep my wallpaper...if possible

    2. I am an admin

    3. Yep, all the tabs
     
  6. mscrx

    mscrx TS Rookie Posts: 829

    you don't need to delete the wallpaper. just disable the feature in the display settings, reboot and see what happens. if all is back to normal you can set your wallpaper up again and try another reboot to see if the "error" comes back.
     
  7. Cephas

    Cephas TS Rookie Topic Starter Posts: 78

    Disable what feature? Active desktop?
     
  8. mscrx

    mscrx TS Rookie Posts: 829

    the wallpaper, set it to none - as kimsland said
     
  9. Cephas

    Cephas TS Rookie Topic Starter Posts: 78

    Okay...i've set it to none... it's restarted a few times so I put it back on a wallpaper yesterday and guess what? When I logged on today I got the same old "Active Desktop Recovery" message...

    Any way to fix this without actually setting my wallpaper to none?
     
  10. mscrx

    mscrx TS Rookie Posts: 829

    which operationg system do you use again?
     
  11. Cephas

    Cephas TS Rookie Topic Starter Posts: 78

    Windows XP, home
     
     
  12. mscrx

    mscrx TS Rookie Posts: 829

    did you check your desktop settings? I mean right mouse click somewhere on the desktop where it is blank, select properties > tab desktop, click "customize desktop", select tab web and make sure there is nothing except the default entry "My current homepage". also check you desktop for any links that might be connected to a resource from the internet. what kind of wallpaper do you use? is it just an image or something a program creates (e.g. some kind of random wallpaper program)?
     
  13. Cephas

    Cephas TS Rookie Topic Starter Posts: 78

    ¬_¬ No I didn't check my desktop settings when I had a problem with my desktop... *Sigh* (Sorry for the sarcasm but I wrote it in the first post)

    And also, no. No desktop changing programs...
     
  14. mscrx

    mscrx TS Rookie Posts: 829

    sorry didn't remember your first post and lazy as I am didn't read it again...
    I am not sure if xp home edition has/supports that but can you do this:

    Run regedit and have a gander at these keys:

    User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]

    Name: NoActiveDesktop

    Type: REG_DWORD (DWORD Value)

    Value: (0 = disable restriction, 1 = enable restriction)


    There would not normally be any "activedesktop" policies in the right pane and you can delete any there that you see.
    However you force disable active desktop by adding the NoActiveDesktop value and setting it to 1 (which enables the restriction)
     
  15. kimsland

    kimsland Ex-TechSpotter Posts: 18,353

    Hang on so when the wallpaper was set to none it worked ?

    If so, then the wallpaper you are using is a Web wallpaper, which is causing the fault.
    Saving your wallpaper into Paint and then saving it as Mywallpaper.bmp to your My Pictures folder. Then right clicking on your new Mywallpaper.bmp picture and setting as wallpaper, should resolve all of this.
     
  16. Cephas

    Cephas TS Rookie Topic Starter Posts: 78

    Lol, no it's not a web wallpaper, it's a picture, i'm sure of it.
    And also i've tried lots of different wallpapers, it's all the same...
     
  17. Cephas

    Cephas TS Rookie Topic Starter Posts: 78


    I looked for "NoActiveDesktop" in both those places but there wasn't anything there... or anything to do with active desktop...
     
  18. mscrx

    mscrx TS Rookie Posts: 829

    did you try the registry keys?
    and do you have a different user account on this machine to see if it is only about your profile?
     
  19. Cephas

    Cephas TS Rookie Topic Starter Posts: 78

    Yeah, as I just said...i've done the keys and I have another account but this doesn't happen on that one...
     
  20. mscrx

    mscrx TS Rookie Posts: 829

    ok, I was posting while you answered that.
    did you set the registry key to make sure it is restricted plus reboot?
     
  21. Cephas

    Cephas TS Rookie Topic Starter Posts: 78

    Umm, what registry keys? The ones you told me to look for aren't there...
     
  22. mscrx

    mscrx TS Rookie Posts: 829

    I said not only have a look at those keys. thats what I meant
     
  23. Cephas

    Cephas TS Rookie Topic Starter Posts: 78

    I don't understand... what should I do?
     
  24. mscrx

    mscrx TS Rookie Posts: 829

    Run regedit and go there:

    User Key: [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
    System Key: [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]

    add a dword value in the right pane:

    Name: NoActiveDesktop

    Value: 1 (= enable restriction)


    thats what this:
    However you force disable active desktop by adding the NoActiveDesktop value and setting it to 1 (which enables the restriction)
    means.
     
  25. Cephas

    Cephas TS Rookie Topic Starter Posts: 78

    Umm okay thanks that got rid of the Active Desktop error but now I can't change my wallpaper!

    When I select a new one it won't let me click "Apply" or when I click "Ok" nothing changes... What now!?
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.