'requires graphics driver support for OpenGL 1.3 or higher'

By Milne
Mar 5, 2006
  1. I just recently bought myself a new graphics card, GeForce 6 6600LE 256 mb DDR AGP8X 128 bit, abd got a free game with it called riddick, but when i try to play it the error message...

    'This application requires graphics driver support for OpenGL 1.3 or higher'

    comes up and the game doesnt work, however my other games like age of empires 3 still works, can someone please help me?
  2. Milne

    Milne TS Rookie Topic Starter Posts: 25

    Can someone please help because i am really puzzled and would like to know whether i have to go and download the driver from the internet or whether it shud be on the disk that came with my grpahics card, but i havent fully installed it.
  3. Jimbo420

    Jimbo420 TS Rookie Posts: 356

    The driver let you play that game should be on the CD that came with the the card, but it never hurts to go out and get the latest drivers for your card.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...