TechSpot

Resolution and Color Issues in Full Screen Applications

  1. Okay, so let's get the hardware out of the way first.

    nVidia EVGA GTX 580
    I7-2600k
    16GB Corsair RAM
    Asus P8P67 Deluxe (I think? Can find the box if it's a big deal)
    Windows 7 Pro, SP1

    For displays, I have a Sony Bravia 40' TV running HDMI off of the GPU, and a 32' Zenbo running VGA off of the GPU's DVI.

    Onwards to the issue. Both TV's run fine for what they are, but when I decide to do anything that's a full screen application, two things happen every time. First and foremost, I lost dramatic picture quality. Specifically, my color looks all washed out and grainy, as if I'm going from a 32bit to a 16 - and this will persist until . Secondly, my resolutions get warped, resulting in the process I'm running actually being a little bit larger than my display, thus I lose about an inch on all sides. Also, for some games, such as the new Tomb Raider, I get a message saying that Windows Aero has been temporarily disabled to improve performance. This doesn't always pop up, but does so enough during other more graphically intense games (Crysis) to be a point of concern.

    Here's the tricky part.

    I just tried to screencap this problem, and seemingly it does not exist. That is it say, when I took a screencap of the edges being off, the screencap show they're there. Same with my video quality; the problem doesn't show up on the screencap, despite the fact that I know it's there. I took a before/after picture of my desktop, showing how things are cut off and look terrible... And it's the same image. So this means that my GPU is processing the image properly, but my displays or something to do with how it's getting to the displays is not functioning correctly? But I don't understand this, because this happens across all of my monitors (I've got another E-Machines 720p monitor that I just recently stopped using, and it still does it as well).

    I'm sort of getting frustrated with this. I'm not technologically illiterate, but for the life of me I have no idea what could be causing this. I've tampered with the settings in Windows, and in my nVidia control panel , to no avail. I also know through Driver Genius that all my drivers are up to date.

    Thoughts?
     
  2. St1ckM4n

    St1ckM4n TS Evangelist Posts: 3,479   +624

    Take a photo.

    Do you have up to date NVIDIA drivers?

    Try it with only one TV connected.
     
  3. fimbles

    fimbles TS Evangelist Posts: 1,282   +157

    That is a weird issue. Only thing that springs to mind is the Overscan option on the TV? Though if the problem persists on a monitor I really have no idea?

    Nvidia control panels "adjust desktop size and postition" Though if it only happens in full screen applications then I am left baffled again.

    Sorry could not be more help.
     
  4. Noblesse Oblige

    Noblesse Oblige TS Rookie Topic Starter

    Yes, the problem persists when I have only one monitor plugged in. And because I know Driver Genius to be fickle with display drivers I checked nVidia's site, sure enough there was an update. But it still did nothing for this issue. As for a picture;

    http://I.imgur.com/POLkSKq.jpg
    - Notice the top edge cut off. Can't see the damn menu at the top to save my life.

    http://I.imgur.com/pMiTZ6Z.jpg
    - Anyone who plays a steam game knows that's not how that's supposed to look.

    http://I.imgur.com/Thu6GhW.jpg
    - Left side cut off.

    http://I.imgur.com/ULhhBPI.jpg
    - Meanwhile, back on my desktop, I can't see anything worthwhile on my taskbar, nor can I see the menu bar on my browser.

    http://I.imgur.com/l3Pu6Kj.jpg
    - Desktop cut off.

    http://I.imgur.com/I78dcBs.jpg
    - See where her hair gets cut off?
    http://I.imgur.com/eW7t7Fu.jpg
    - That's where it's supposed to be.

    With my terrible phone quality, I don't seem able to capture how the quality gets reduced during a full screen operation, only the res issues...
     
  5. Noblesse Oblige

    Noblesse Oblige TS Rookie Topic Starter

    Addendum; I somehow managed to get my desktop locked into this mode of terrible color quality after closing the full screen application. It affects only the monitor that the full screen application is on, visually, yet digitally it seems to register the problem on both displays;

    http://I.imgur.com/1vsrUcI.jpg

    Problem here is, everything looks distorted anyways thanks to imgur. More troubling, when I move my browser from this display to the other, I immediately see a quality difference myself. Screencapping it, however, shows the same defect on both displays.

    So my computer is a massive troll, it seems.
     
  6. St1ckM4n

    St1ckM4n TS Evangelist Posts: 3,479   +624

    From the photos, I can't see any color quality problems. What you have is an overscan problem (edges being cut off).

    Plug in a computer monitor ONLY. We'll fix the problem on this first, before moving onto the more tricky TVs. Make sure you're connected via DVI or HDMI.

    Go to NVIDIA control panel, 'adjust desktop size & position'. You'll see a drop-down for 'scaling method. While connected to monitor, this should be set to GPU. While connected to TV, this should be set to SCREEN (with additional adjustments made on the actual TV).

    Play around with these until you get it right on your monitor. Make sure to use native resolution, not some custom res.
     
  7. Noblesse Oblige

    Noblesse Oblige TS Rookie Topic Starter

    Sorry for not responding for a little bit. I was away from home, and I live in Toronto. If anyone's been keeping up with the news, they'd know it's not been fun here the last few days. ><

    Anyways, all issues resolved but the colour going off during some application use, and I can now describe this problem better. When I go into my nVidia display settings and turn my display to 1080i, I get the EXACT same effect as when I turn on a full screen game or what-have-you. Still, print screening has no effect.

    Perhaps this will help?
     
  8. St1ckM4n

    St1ckM4n TS Evangelist Posts: 3,479   +624

    Your tv isn't 1080p? Damn son, what are you doing.

    Use the 'p' resolutions, stay away from 'I' if using computer.
     
  9. Noblesse Oblige

    Noblesse Oblige TS Rookie Topic Starter

    No, it very much is. That's the curious part. It only reverts to that option unprompted during some applications when plugged in via PC. I don't have this problem with the PS3 or anything else.
     
  10. stonarda

    stonarda TS Enthusiast Posts: 183   +17

    I have an AMD graphics card, but see if there are any scaling options in the NVIDIA cards control panel. Adjust it and see if it helps. There also may be some horizontal adjustments that can be made too - if anyone has a NVIDIA card and knows how to do this, then fire away!! Also, sometimes televisions and graphics cards just don't work that well together at all, something that I experience often.
     
  11. Noblesse Oblige

    Noblesse Oblige TS Rookie Topic Starter

    I've already fiddled with those settings. They don't seem to apply to this situation. As previously stated, this issue only occurs on this Sony Bravia, specifically. My others are unphased by whatever this is, leaving me to believe that perhaps this TV just won't work, period, as a monitor. ><
     
     
  12. St1ckM4n

    St1ckM4n TS Evangelist Posts: 3,479   +624

    It'll work. It's an overscan problem, which can be somewhat fixed... but it's not ideal.

    Case in point: my Panasonic plasma needs to be set to: scaling via display (nvidia settings), native 1366x768 resolution set on Windows, 'Zoom 2' aspect ratio set on TV.

    Basically, set scaling to display and native resolution, then play with the aspect ratio and 'input label/name' on your TV. Either it'll work okay, or you'll give up and realise that's why TV's suck for monitors. :)
     
  13. Noblesse Oblige

    Noblesse Oblige TS Rookie Topic Starter

    And it seems the issue is, strangely enough, that the TV tries to drop the frequency over HDMI during previously mentioned applications. Not sure why, but I can't find a fix for it anywhere. At least it's properly identified. Bah!
     
  14. St1ckM4n

    St1ckM4n TS Evangelist Posts: 3,479   +624

    NVIDIA control panel has the ability to save application profiles. This means you can set certain applications to behave in certain ways when they are in use. Perhaps this is the problem?

    It hasn't been mentioned ,but you should do a 'clean install' of the latest NVIDIA drivers. You only say you installed the update - the 'clean' option is required to wipe all application profiles.
     
  15. tipstir

    tipstir TS Ambassador Posts: 4,752   +96

    Simple fix I have the SONY BRAVIA 40-inch and 46-inch shown below is 40-inch. I had to re-sized the picture for it to fit here. Below Picture 1 shows 1920x1080p HDMI-2 Connection. P71500143.jpg

    On the Settings of the SONY you need to make sure you have the right Screen settings HDMI2.
    P71500192.jpg

    On the GPU Setting through the Driver shown (AMD) varies on Intel, NVIDIA, VIA, MSI etc.
    P71500215.jpg
     
    St1ckM4n likes this.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.