Router Problem

By ClassicD
Jul 12, 2003
Topic Status:
Not open for further replies.
  1. Ok, I have a network at home with 3 PCs connected to my Belkin, 4-Port Ethernet Cable Router. The problem is getting various messenger programs to let me send files (I can receive them) and games to allow me to play IP to IP (most notably, Command And Conquer Generals).

    When my PC is hooked up to the router, it says my IP is 192.168.2.39. When it's unplugged and the cable is fed directly to the PC, the IP is totally different. I've been told I need to place my PC in the DMZ, which will mean there should be zero problems with files/ports, etc, which I'm happy to do. However, it says I need to input the IP of the PC I want to place in the DMZ, and it only lets me change the last figure in the IP address for this, not the '192.168.2.' before it. The IP of the PC is, as I've said, nothing like the one when it's hooked up to the router.

    I cannot figure out why it won't let me place the PC outside the firewall and into the DMZ, why it won't let me put in the other IP.

    Any help would be appreciated, the router has solved the problem of me not getting onto the PC due to others using it, but is driving me up the wall with it's firewall and port problems.

    Cheers
  2. XtR-X

    XtR-X Newcomer, in training Posts: 1,040

    The router changes the IPs so you can share an internet connection for instance.
  3. ClassicD

    ClassicD Newcomer, in training Topic Starter

    Ok, but how come when I put the supposed IP of the PC I want to use into the DMZ, it doesn't have an effect on sending files, IP to IP games, etc? It just behaves as if it's still stuck behind the router. How do I get it NOT to behave like this?
  4. Nic

    Nic TechSpot Paladin Posts: 1,928

    Have you enabled the DMZ port for your router and check your router configuration page using your browser?
  5. ClassicD

    ClassicD Newcomer, in training Topic Starter

    Yes I checked my router config via my browser, and it says my DMZ is enabled and the PC with IP 192.168.2.39 is placed in the DMZ.
  6. Nodsu

    Nodsu Newcomer, in training Posts: 9,431

    192.168.*.* addresses (10.*.*.* and 172.*.*.* too) are IP addresses reserved for LANs, these "private" IPs are never used across the internet.

    When you connect to your ISP, you are assigned one global IP for use on the internet. Your router performs magic called NAT (Network Address Translation) and routes traffic from many local IPs to the internet and from the internet to many local IPs.

    Even though you may have many PCs in your local network, for the internet it looks like a single device is communicating, because for the outside world only one IP is seen.

    If you want traffic to come through the firewall, you enable DMZ (a bad idea) or port forwarding (a much better idea). You tell the router to forward traffic to a local IP (your PCs IP, 192.168.*.*). If you are using DMZ, then it does not put your PC outside the firewall, your PC just receives all traffic from the internet that is not explicitly blocked on the router. Your PC will still have the private IP it is assigned and the router does the address translation.

    When you want to communicate through your firewall.
    In the software configuration (p2p, games, etc) where you are asked for your IP address, you must enter the outside IP, not the IP Windows tells you have.
    You can find that IP on the status page of your router setup. Many programs and services (IM namely) are able to detect your outside IP automatically and you do not have to worry about the IP.

    It may be that your IP is dynamic, in this case you have to check the software configuration every time you have been disconnected from your ISP. In case of a dynamic IP, it is good to sign up to a dynamic IP service like www.dyndns.org that gives you a fixed hostname that always points to your correct IP. Some router support dynamic hostname services, so you don't need any extra software to update the hostname every time you connect.
  7. DigitAlex

    DigitAlex TechSpot Paladin Posts: 583

    i have a similar setup at home

    no problems sending files with AIM or Yahoo IM. MSN Messenger uses UpNp so if your router does not support it you can just forget about sending any files with MSN Messenger (I did forget about that)

    Playing IP to IP involves establishing a direct connection between the machines

    if your machine is emitting the request then it's ok
    if you have to act like a server, then you should just enable port forwarding NAT in your router's settings and all works fine (when u wanna run a FTP / WWW / CS / UT / Q3 server for example)
  8. Nodsu

    Nodsu Newcomer, in training Posts: 9,431

    ???

    My router definently does not support upnp and furthrmore, i have the service disabled in windows. And file transfer works just fine, just had to open the right ports on the firewall.
  9. DigitAlex

    DigitAlex TechSpot Paladin Posts: 583

    can you send files with MSN messenger from a pc that is behind the router ?

    if so, tell me how...
  10. Nodsu

    Nodsu Newcomer, in training Posts: 9,431

    MSN file transfer wants incoming TCP ports 6891-6900
  11. DigitAlex

    DigitAlex TechSpot Paladin Posts: 583

    so you mean that to SEND files i must enable NAT port forwarding on those ports for ENTERING connections ???

    (i dont have any firewalls blocking those ports)
  12. DigitAlex

    DigitAlex TechSpot Paladin Posts: 583

    hmmm i tested and it worked great

    never worked before though, must be new stuff in msn6 or smth

    anyway thx a lot nodsu
  13. Nodsu

    Nodsu Newcomer, in training Posts: 9,431

    I have MSN 5 BTW.. (just to remove the last strips of dignity DigitAlex has left.. *eg*)
     
  14. DigitAlex

    DigitAlex TechSpot Paladin Posts: 583

    no comment ...
  15. poertner_1274

    poertner_1274 secroF laicepS topShceT Posts: 4,745

    Well unfortunately I cannot send files with AIM or MSN or DCC in IRC. Any suggestions? I am using a Netgear RO318 router. I also do not have that much home networking knowledge, so I am willing to gain anything I can to fix this problem, as well as be able to run a webserver, ftp, and email client on one of my networked computers. Any docs or tips are welcome. Thanks everyone.
  16. JSR

    JSR Banned Posts: 730

    LMAO

    for ...........removing the last strips of dignity ...........digitalex has left.........nodsu very much :grinthumb
  17. Nodsu

    Nodsu Newcomer, in training Posts: 9,431

    Well, AIM wants to use port 5190 for file transfer.
    I already mentioned the ports you need to forward for MSN.
    You can set the DCC ports to be used manually in mIRC configuration.
    I haven't set up my yahoo or ICQ for file transfer so I don't know about these.
  18. obsideo

    obsideo Newcomer, in training

  19. Newbigger

    Newbigger Newcomer, in training

    Opening port problem

    I am using a linksys router and I opened two ports to use ftp. But I get a connection error and winsock error. Did I something wrong when I opened the two ports? Or do I have to do something to get them to stay open?
  20. Nodsu

    Nodsu Newcomer, in training Posts: 9,431

    If you want to download things you don't really need to open any inbound ports on your firewall. Just set your FTP client to use passive mode. If you want, you can open some ports for active FTP. Make sure your FTP client software lets you specify wich ports to use.

    If you want to run a FTP server, then you need to open incoming TCP port 21 for control. If you want your FTP server to be more useful, open at least some ports for data transfer. Make sure you have FTP server software that allows you to specify wich ports (if any) it should use.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.