Router problems, need a pro's help!

By leon158
Dec 16, 2007
  1. I'm currently using a wireless connection by iZZi which comes with a receiver and modem in 1 and the internet connectivity is impressive. Recently another user needed the internet access under the same roof and I installed a Wireless router with 4 cable ports as well. For the main computer, i used a Lan cable to connect to the router. There was internet connectivity but the performance dropped greatly. Bittorrent downloads can only go 1 at a time and it was much slower than without the router. And another thing, I was no longer able to log in to windows live messenger. Without the router, I used to log into windows live messenger within 1-2 seconds but through the router, it keeps telling me to check my internet connection. Please advice, I'm running out of ideas
  2. raybay

    raybay TS Evangelist Posts: 7,241   +9

    What is the brand and model of the wireless router? What country are you in?
  3. mikescorpio81

    mikescorpio81 TS Rookie Posts: 293

    Change the wireless channel on your router.
    If it's currently set to 11, change it to 5 or similar.
  4. leon158

    leon158 TS Rookie Topic Starter

    Changing the channel didn't work. It's a Belkin Wireless G Router and I'm from Malaysia.
  5. commission

    commission TS Rookie Posts: 26

    Has it got the latest firmware?
  6. mikescorpio81

    mikescorpio81 TS Rookie Posts: 293

    Take the 2nd router out of your network and test to see if all goes back to normal.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...