TechSpot

Running Both Office 2003 and Office 2007 help

By dustinl15
Jan 15, 2007
  1. I have both Office 2003 and Office 2007 installed. I can use either or with no problems. But if I click on a file it will always open it with Office 2003. I have Office 2007 setup to run in Compatability Mode and always save the files in the .xls format. The only way I can open a file in Office 2007 is to go through the program and not just by double clicking the file. I have tried to change the Open With in the properties of the files but it changes back to Office 2003 after I set it to Office 2007. Any Ideas on how to make it always use Office 2007 as my default.
     
  2. kitty500cat

    kitty500cat TS Evangelist Posts: 2,154   +6

    Right click on the .xls file you want, and choose Open With. Select Excel 2007; then below the box with all the available programs, there should be a check box that says something like "Always use the selected program to open this type of file." Check that box, and it should always open w/Excel 2007.

    hope it helps

    --kitty
     
  3. dustinl15

    dustinl15 TS Rookie Topic Starter Posts: 41

    Ok, I tried that, I had to browse for Excel 2007 and selected it and checked the box, but the file still opens with 2003. Even if I created it in 2007 then try to open the file it opens in 2003.
     
  4. kitty500cat

    kitty500cat TS Evangelist Posts: 2,154   +6

    oh. I don't know then. I guess a more experienced TechSpot member is gonna have to help you out here.
     
  5. N1Hawk

    N1Hawk TS Rookie Posts: 222

    How about remove Excel 2003 and just use Excel 2007?
     
  6. dustinl15

    dustinl15 TS Rookie Topic Starter Posts: 41

    I want to keep 2003 for a few more months. Not all of our systems are ungraded to 2007 yet. Just as a precaution, I guess.
     
  7. RealBlackStuff

    RealBlackStuff TS Rookie Posts: 6,503

    Just rename the excel.exe from Office 2003 to e.g. excel3.exe.
    Then change the 'Open with..' to excel from Office 2007.
    That way it's still there, but no longer automatically accessible.
     
  8. Tedster

    Tedster Techspot old timer..... Posts: 6,000   +15

    screw both of those. Use open office.
     
  9. matt2971

    matt2971 TS Rookie Posts: 28

    I had this issue with a user PC at my work, but the other way around. I fixed it by running a repair (via the add/remove dialogue) on the version we wanted to be the default.
     
  10. iceicelady

    iceicelady TS Rookie

    Thank you, Matt! This fixed my problem. I installed selected 2007 applications (just Word, Excel, and PowerPoint), but still wanted to keep my 2003 apps as the defaults. (Doing the "Open With > Choose Program..." thing wasn't working.) But running a repair on Office 2003 was just the ticket.
     
  11. christina2009

    christina2009 TS Rookie


    thanks so much for useful info
     
  12. strategic

    strategic TechSpot Paladin Posts: 1,020

    This is something very simple. Assuming you are running XP, (other o/s versions should be similar).
    Your file associations need to be set:

    * open 'my computer'
    * click on 'tools' in the menu bar
    * click on 'folder options'
    Under the 'file types' tab, search for the extension of the file(s) in question (you can only do one file type at a time) oce you select the file type, change the program you want to use to open it.;)

    Note: this is almost like right-clicking the file and choosing open with. 'open with' is teporary, the steps above are permanent :D
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...