Safecom 2 port combo, Need help!

By Lasty
Sep 21, 2007
  1. Hi guys so i want to connect my xbox 360 to xbox live using my Safecom 2 port combo router. Anyways i used to have it connected up and everything worked fine, untill i reset the router by mistake... I have all the settings correct and all the connections are fine except for my dsl, its the one thing that doesnt work, I have the adsl plugged into the phone jack thing, seems to work fine for my modem but when i try it with my routers adsl cable, i cant connect, Seriously i tryed waiting for over an hour. So if anyone on here can give me some help, Which i need urgently, HALO 3 ON WEDNESDAY...Need i say more lol, that would be great! BTW i keep keep getting "Dsl is disconnected" when i go to connection status. If that helps...

    All help will be appreciated, Thanks
  2. Po`Girl

    Po`Girl TS Rookie Posts: 595

    So you have gone into the setup page ( and entered ISP login info.

    You have saved settings and rebooted.

    On the diagnostic test page, where exactly does it fail ?

    I never had any luck with Safecom routers (they both pooped out in a year).
  3. Lasty

    Lasty TS Rookie Topic Starter

    Er i actually use And yes i have saved the settings the settings and reset the pc many times, i belive the problem is with the frikking phone jack in thw wall, mainly because its old as hell... But thanks for the post!
  4. Po`Girl

    Po`Girl TS Rookie Posts: 595

    And where does the diagnostic page say the problem is ?

    That is what the page is for.

    Re the wall jack : If your ADSL modem synchronizes,and connects Ok,

    then it probably isn`t that.
  5. Lasty

    Lasty TS Rookie Topic Starter

    Er well basically i try to connect and it says connecting, for about na hour and when i go to connectivity status it tells me that the problem is that the dsl is disconnected, and thats all i know... And no it doesnt connect if you were wondering..., FOr me there is no Diagnostics Page for some reason
  6. Po`Girl

    Po`Girl TS Rookie Posts: 595

    Most Safecoms do have a test page somewhere.

    What is is your model number ?

    The Safecom router support and FAQs page is here HERE

    Just enter your model at the top right.
  7. Lasty

    Lasty TS Rookie Topic Starter

    Yo , er actually this morning my pc gave me the blue screen of death, seen as it was way to old to begin with my mum and i decided to go to pc world and get a new one, So now i have vista and a new Netgear Wireless Router, which guess what? Im also having problems with! So i have an adapter for my 360 and that wont connect to it, it picks it up but thats all, My psp picks it up and says that i have a dns error, Any idea how to set up a Dns account? Just im stomped, Vista is pretty easy to work with and AWESOME! ,im just now installing Avg on it, So any help would be much appreciated!!
  8. Po`Girl

    Po`Girl TS Rookie Posts: 595

    You had better start a new thread with this one.
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...