TechSpot

Samba up, but only able to share CDROM.

By novkhan
Apr 27, 2004
Topic Status:
Not open for further replies.
  1. My Samba have been set up and now i can share my CDROM between 2000 .
    Using my network place---Workgroup---CDROM from 2000.

    I tried to put my Root folder from RH9 to share .

    I used my win 2000 to access the folder ,
    i get a message

    " \\Localhost\root is not accessible. The network name cannot be found"

    But the strange is that i can access RH9 CDROM folder from WINDOWS!

    i wonder if my Samba setting is set right!
    But my CDROM settings from Samba is exactly the same as ROOT settings.
    The Samba settings is displayed below.

    Base Options:
    path: /root

    Security Options:
    guest account :nobody
    read only:Yes
    guest ok: No

    Browse Options
    Browseble :Yes

    Miscellaneous Options
    Available: Yes

    I have also tried playing resetting the Base Option
    Base Options:
    path: /10.0.0.13/root

    but still it doesn't work
  2. Didou

    Didou Bowtie extraordinair! Posts: 5,899

    First of all, there is no need to create multiple threads for the same problem.

    & as allready said in your other thread, if from the windows machine you are trying to access localhost, you are accessing THE WINDOWS MACHINE, not the Linux machine.

    localhost refers to the machine you are working on, not the machine you are connecting to.
  3. novkhan

    novkhan Newcomer, in training Topic Starter Posts: 37

    Oops sorry for that!

    Here is my samba.conf file. Please Help!

    # Samba config file created using SWAT
    # from localhost.localdomain (127.0.0.1)
    # Date: 2000/04/30 15:56:56

    # Global parameters
    [global]
    server string = Samba Server
    encrypt passwords = Yes
    obey pam restrictions = Yes
    pam password change = Yes
    passwd program = /usr/bin/passwd %u
    passwd chat = *New*password* %n\n *Retype*new*password* %n\n *passwd:*all*authentication*tokens*updated*successfully*
    unix password sync = Yes
    log file = /var/log/samba/%m.log
    max log size = 0
    socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
    dns proxy = No
    printing = cups

    [homes]
    comment = Home Directories
    valid users = %S
    read only = No
    create mask = 0664
    directory mask = 0775
    browseable = No

    [printers]
    comment = All Printers
    path = /var/spool/samba
    printable = Yes
    browseable = No

    [cdrom]
    comment = Share CDROM
    path = /mnt/cdrom

    [windows]
    comment = Windows File
    path = \\10.0.0.13\mnt

    [root]
    comment = root
    path = \10.0.0.13\root
    guest account = novkhan

    Tried \\10.0.0.13\...
    //10.0.0.13/......
    all sorts of way but in vain!

    Onli able to share CDROM!
    strange huh!.....
  4. Nodsu

    Nodsu Newcomer, in training Posts: 9,431

    You are supposed to specify pathnames, not network addresses.

    Forget the IP addresses: you should specify the root share just like the CDROM share:
    [root]
    path=/

    And while you're at it..
    [windows]
    path=/mnt

    And the slashes go forward in Linux when you are defining path names.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.