TechSpot

SATA QUESTIONS (onboard & PCI card)

By degsygordon
Jan 13, 2004
Topic Status:
Not open for further replies.
  1. Folks,

    My Motherboard (Gigabtye INXP8) has on-board SATA with the Silicon Image 3112 controller card. I have installed windows XP and everything is working fine. Now, my motherboard only has two SATA slots, which I want to increase for additional drives.

    So I have bought an additional PCI SATA controller card (which happens to be a Silicon Image 3112 card as well). When I have a device attached to the PCI card my PC won't boot. I have even tried attaching the bootable Hard Disk onto the PCI card but it still doesn't boot!

    I have heard that if you add a SATA PCI controller than it tries to boot off this first? I'm assuming you can use the on-board controller and the PCI controller? Can someone confirm.

    The exact error I receive is:
    PDC 20276 BIOS is not installed because there are no drives attached.

    As I have said above, it all works fine if I use the on-board SATA controller with no drives attached to the PCI SATA controller.

    Any details/feedback is appreciated.

    Thanks
    Derek
  2. Nodsu

    Nodsu Newcomer, in training Posts: 9,431

    There may be a setting in BIOS that sets whether to boot from an offboard device first. You may also have to change some settings in the PCI controller BIOS. Try putting the PCI controller in another PCI slot. (First and last slots are not a good idea).
  3. degsygordon

    degsygordon Newcomer, in training Topic Starter

    >There may be a setting in BIOS that sets whether to boot from >an offboard device first.
    I can't see any settings like this in the BIOS! You can just enable or disable the on-board controller - It is currently enabled.

    >You may also have to change some settings in the PCI >controller BIOS.
    Can't change anything!

    >Try putting the PCI controller in another PCI slot. (First and >last slots are not a good idea).
    It's currently not set on the first or the last PCI slot - Can try and move it thou!
  4. Greeno

    Greeno Newcomer, in training Posts: 394

    PDC20276 is a Promise RAID Controller
  5. Greeno

    Greeno Newcomer, in training Posts: 394

    do you mean GA-8INXP ? The Granite Bay chipset board..?

    If so you'll have 2 'Green' IDE slots which are a promise RAID controller...
  6. degsygordon

    degsygordon Newcomer, in training Topic Starter

    >do you mean GA-8INXP ? The Granite Bay chipset board..?
    Yip - That's right.

    >if so you'll have 2 'Green' IDE slots which are a promise RAID >controller...
    I'm only using IDE for my CD-ROM. All my HD's are SATA's. When I have my boot drive plugged into the SATA on-board then everything works, the second I try to add a HD on this additional PC controller I have - It doesn't work and I get the error:

    PDC 20276 BIOS is not installed because there are no drives attached.

    Anyone any idea what could cause this?

    Thanks
    Derek
  7. Greeno

    Greeno Newcomer, in training Posts: 394

    Yes, Obviously... well... you've just stated, you've only got a CD-ROM on this channel... (i.e. No Hard drives) so you're going to receive this error.

    I'll be honest with ya mate, having worked with the GBT range for years now, your best bet is to flash to the latest BIOS, because i've been noticing they've become more and more configurable of late, with the options of "Boot from : Floppy/CD,DVD/HDD-0/Boot add-in card etc.." but you'll keep getting this message until you put your CD-Rom onto the White or Red port on your mobo and disabling the Promise controller altogether.

    As for your other problem, we'll look at that once this 'quirk' is remedied.
  8. degsygordon

    degsygordon Newcomer, in training Topic Starter

    >CD-Rom onto the White or Red port on your mobo and disabling >the Promise controller altogether.
    CD-Rom was on the White port - Just had to disable the promise adapter and all is well here.

    Still having a problem when I connect my PCI SATA Controller and try and use the on-board as well?

    Anyone else had any problems like this?

    Thanks
    Derek
  9. benjamin

    benjamin Newcomer, in training

    > Anyone else had any problems like this?

    I have a gigabyte 7vaxp mainboard (2 regular ide + 2 ideraid (promise 20276), no sata). Boot HD is on ide0, cdrom on ide1, and 2 drives on the ideraid (in raid mode). All working fine.

    Then, I added a promise s150tx4 sata raid card. Now, the computer boots as far as the loading-an-OS-off-a-drive step and then stops with a blank screen - that's even with no sata drives attached. If I disable the ideraid, it boots fine. So, the problem doesn't seem to be that it's trying to boot off the sata raid; rather, it seems to be a problem with the two promise controllers in the same box. Can't find any word about that on the net.

    I've shuffled PCI cards, turned off unwanted things on the mainboard like the firewire, flashed the mainboard bios, you name it. With both raids enabled/plugged in, I can boot from a win2k cdrom - but it locks up very early on in the cd's startup sequence.

    Any suggestions are welcome :)
  10. benjamin

    benjamin Newcomer, in training

    Follow-up:

    I tried the sata card in another computer with on-board (older version though) promise ide raid, with the same results.

    The sata card is now in a third computer, free of other promise hardware, and is working happily.
  11. lowman

    lowman Newcomer, in training Posts: 446

    Any updates to this issue? Kind of interested in what the fix is...
     
  12. borg1

    borg1 Newcomer, in training

    I put a PCI SATA controller and drive in my A7V which already has an IDE boot HDD, and all I get on boot is the message 'press any key to reboot'. The best concept I got when asking around is to hard jumper the drives as master and slave. With two controllers and no way to designate primary/secondary in MB bios, this may be the only solution short of rewriting the card or MB bios (assuming it IS a solution). I will try this when I get a few more pressing issues with other machines addressed.

    A point one of our FA engineers made is if you put two boot drives with XP in the same machine and try to boot, it will reverse the swap files. He toasted one of his experimental machines this way.
  13. mated5

    mated5 Newcomer, in training

    Hi,
    The following is the email exchange I've been having with Promise support. So far I'm up to the point where they say you cannot run two Promise controllers in the same computer (do you know if this is true?) even if one is IDE and the other SATA.

    Anyone have any suggestions?

    Sorry about the long post, but editing it down might loose some of the content (like it really doesn't look like they understand the emails before answering them)

    ----Email exchange with Promise Supoort ----------------------
    Hi,
    Could you check what the conflict between the IDE controller and the SATA controller is for me. If I knew what the conflict was, maybe I could get a solution from GIgabyte or from Mr. BIOS.

    If you don't personally know what the problem is, could you please ask one of the engineers (or pass this email up to them).

    Thanx
    ...MaTed

    On Wed, 02 Nov 2005 12:11:12 -0500, support <support@promise.com> wrote:

    Hi
    Sorry I don't know if there is any way to configure so the two controllers (onboard PDC20276 and SATA300) can be used at the same time.


    Thank you
    Promise Technical Support
    Promise Technology Inc
    Phone 408-228-1400
    Faxed 408-228-1079


    -----Original Message-----
    From: Ted Ma [mailto:?????@sympatico.ca]
    Sent: Tuesday, November 01, 2005 6:52 PM
    To: support
    Subject: Re: Cannot boot with SATA drives connected to SATA300 tx2Plus

    Hi,
    There is only 1 on-board SATA controller (Silicon Image Sil3112A) and is disabled in the BIOS. The two other controllers are IDE. One is the regular IDE (from southbridge - see previous email) and the other is the IDE RAID controller (Onbard Promise PDC20276).

    The two optical and two IDE 60 GB are configured as detailed in the previous email.

    The system does boot from the IDE drive (first channel) on the Promise PDC20276 with no SATA drives connected (BIOS does not load for PCI SATA300 TX2Plus).

    I only have the PCI SATA300 TX2Plus as a SATA controller.

    Is the On-board IDE RAID controller (Promise PDC2076) not compatible with the PCI SATA300 TX2Plus???? Is there no way to configure so the two controllers can be used??

    Yes the system boots normally with just the 2 IDE controllers (Promise and regular southbridge) enabled. It used to work with the on-board SATA
    RAID enabled as well (this has been disabled)

    ...MaTed

    On Tue, 01 Nov 2005 14:08:27 -0500, support <support@promise.com> wrote:

    Hi
    It seem like you are trying to run all SATA controller in the same system. (Onboard Silicon SATA, PDC20276 and PCI SATA300 TX2Plus) If so
    there is chance that 2 of the controllers will encounter conflict.

    I know for fact that the PDC20276 and PCI SATA300 TX2Plus will run into conflict because both controllers are manufacture from promise. Usually with promise controller you can only have one controller working pre system.

    Does the system work if you only have 2 out of 3 controllers running?

    Thank you
    Promise Technical Support
    Promise Technology Inc
    Phone 408-228-1400
    Faxed 408-228-1079

    -----Original Message-----
    From: Ted Ma [mailto:?????@sympatico.ca]
    Sent: Monday, October 31, 2005 4:01 PM
    To: support
    Subject: Re: Cannot boot with SATA drives connected to SATA300 tx2Plus

    Hi,
    The onboard SATA RAID controller (On-Board SATA RAID *
    - Onboard Silicon Image
    - Supports Disk striping (RAID0) or DISK
    Mirroring (RAID1)
    - Supports UDMA up to 150 MB/sec)
    is disabled in the BIOS. It went bad on the Drive side - It was still recognized by the Windows
    XP driver but was sporadic on recognizing the drives. The onboard controller was not running in raid mode.

    The on-board regular IDE (? Onbard Promise PDC20276
    - Supports data striping (RAID 0) or
    mirroring (RAID 1)
    - Supports concurrent dual IDE controller
    operation
    - Supports IDE bus master operation )
    has a DVDRW drive as the Primary Master and a DVD drive as the Secondary Master.

    The on-board IDE RAID is being used as simple IDE. Channel 1 has a 60 GB Hitachi drive as Master. Channel 2 also has a 60 GB
    Hitachi Drive. I do want to RAID the two drives later as data storage, but for now Channel 1 is the Windows XP boot drive.

    It's a SATA300 TX2Plus, not that it matters much.

    If you need the manuals (3 of them). I can try sending them to you, but they are large (7.2 MB, 800 KB and 420 KB). Do you have a FTP site I could send to (or I can find the links and point
    you to them)

    ...MaTed

    On Mon, 31 Oct 2005 12:50:55 -0500, support <support@promise.com> wrote:

    Hi
    Are you running both the onboard Ultra controller and SATA150 TX2Plus at the same time? Also the onboard Ultra controller is this controller also Promise chipset controller?
    Thank you
    Promise Technical Support
    Promise Technology Inc
    Phone 408-228-1400
    Faxed 408-228-1079

    -----Original Message-----
    From: Ted Ma [mailto:?????@sympatico.ca]
    Sent: Friday, October 28, 2005 7:18 PM
    To: support@promise.com
    Subject: Cannot boot with SATA drives connected to SATA300 tx2Plus


    I bought the Controller to replace the on SATA controller on a Gigabyte GA-7vaxp ultra. I have 2 Hitachi 7k250 160 GB SATA drives. When
    the SATA drives are connected, the sytem will not boot. It seems to get to the point where it loads the boot sector on (screen goes blank) and the
    system stops if either SATA dive is connected (ie tx300 BIOS loads). If I rearrange the boot order, the system will try to boot from either of SATA
    drives. The IDE drives are connected to the onbound RAID controller non-RAID configuration.


    --
    ...MaTed (Ted Ma)
  14. designer

    designer Newcomer, in training

    Promise PCI controllers vs onboad controlers

    Anyone ever find a resolution to this? I have been battleing with the same sort of problem. A Promise TX4300 SATA RAID, PCI controller going onto a ASUS A7N8X Deluse MoBo, with a Silicon Image 3112a SATA RAID controller onboard. Same sort of problems you people have discussed. Even with the onboard controller disabled through jumpers, as soon as a drive is attached to the tx4300 hangs at bootup. Promise, ASUS neither seem to know a solution.
  15. mated5

    mated5 Newcomer, in training

    I bought a new MB instead

    After months of trying to get the combination to work, I bought another Motherboard instead - with onboard SATA. Promise and Gigabyte support didn't help other than suggesting all the things I had already tried.

    If anyone actually gets this working, please also send me a message, I'd love to know if it was possible.
    ...MaTed
  16. designer

    designer Newcomer, in training

    PCI RAID Controllers vs Onboard

    Mated
    Do you have any onboard LAN devices? NVIDIA chipset?
    I have been successful in getting the ASUS A7N8X DELUXE rev. 2.0 with onboard Silicin Image 3112ac SATA RAID controller to work great with a PCI Promise TX4300 SATA RAID controller. 2 different RAID 0 arrays on the promise controller + JBOD on the Silicon Image controller. Still a conflict with the LAN, only NVIDIA though. Works fine with a 3com LAN. Boots up to the first array on the Promise. Win XP Pro.
  17. mated5

    mated5 Newcomer, in training

    Tried different LAN

    I had onboard LAN, but I it was disabled and a PCI Ethernet card used. The board didn't have Nvidia chipset (video was Nvidia though). My on-board SATA controller stopped working and was disabled (3112a) but the Onbard Promise PDC20276 (IDE RAID controller) was still enabled. I suspect the two Promise controlers were having a problem with each other (disabling the IDE RAID and removing the IDE drives made the system at least get further - no O/S).
  18. designer

    designer Newcomer, in training

    Re tried different LAN

    Disable all onboard / integratd peripherals first. Remove PCI controllers. Then remove drivers for all RAID and / or SATA / IDE controllers. Then install PCI controller & drivers for same. Load OS. Then install other controllers & drivers, one at a time, reooting between each. thus allowing system to set best order of device assignments. After all this, reenable onboard peripherals one at a time.
    Seems like a long winded method. But hopefully it will be of help to you.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.