Screen chugs while browsing web.

By Jinto
Jul 10, 2007
Topic Status:
Not open for further replies.
  1. Hello everyone. Recently I reinstalled Windows XP on my computer due to prior complications (desktop kept freezing). I have reinstalled most of my favorite and necessary programs. Everything was going smoothly until I opened up Firefox to browse the web. When visiting a web site I noticed that scrolling up and down was very sluggish. My Dell monitor supports 1600x1200 resolution, however it will not allow me to select that resolution. The highest it will go to is 1280x1024. Does it have something to do with my graphics card perhaps? This was not a problem before I reinstalled Windows XP so there must be something I have to install or update. Or it may just be as simple as checking a box. Any ideas?

    P.S. Forgive me for not listing my system specs as I am not exactly sure what to give you. I wouldn't want to display anything that may put my computer at risk. Not that I don't trust any of you or anything. =)
  2. kpo6969

    kpo6969 TechSpot Maniac Posts: 875

    Did you re-install all your drivers?
  3. Char_X

    Char_X Newcomer, in training Posts: 209

    Yeh...try to reinstall your video drivers
  4. kpo6969

    kpo6969 TechSpot Maniac Posts: 875

    What is that suppose to mean?
  5. Jinto

    Jinto Newcomer, in training Topic Starter Posts: 49

    Yep, that's exactly what the problem was. I thought I had reinstalled my Nvidia graphics card driver but I guess I didn't. Thanks for the help guys.
  6. Tedster

    Tedster Techspot old timer..... Posts: 10,067   +13

Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.