TechSpot

scvhost.exe need help tried for days to delete

By fatalpastry
Feb 27, 2007
  1. not sure how i got this but its a spyware/trojan thing been looking all over the net on how to fix tried many things such as wintasks and hijack this spybot search and destroy hijack this msconfig disable start up safemode and run hijackthis and nothing has worked file always copies itself back to like 5 registry places what should i do

    heard that these logs help to solve problem so here is one
     
  2. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Hello and welcome to Techspot.

    Your system is badly infected with a variety of nasties.

    Very Important: Before deciding whether you should clean or reformat your system, go and read this thread HERE and decide what it is you want to do.

    If after reading the above, you wish to clean your system, do the following.

    Go and read the Viruses/Spyware/Malware, preliminary removal instructions. Follow all the instructions exactly.

    Post fresh HJT and AVG Antispyware logs as attachments into this thread, only after doing the above.

    Regards Howard :wave: :wave:

    This thread is for the use of fatalpastry only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  3. fatalpastry

    fatalpastry TS Rookie Topic Starter

    ok im not sure what happend but i am stuck on step 10 becuase my folder that it tries to download in documents and settings or what ever keeps automatically getting switched to read only by something

    i keep trying to uncheck it and hit apply but soon as i try to download tool1 it just says the folder is read only
     
  4. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Try downloading the tools to a different location, such as your desktop.

    Regards Howard :)

    This thread is for the use of fatalpastry only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  5. fatalpastry

    fatalpastry TS Rookie Topic Starter

    well the virus i have is called wm32 bot-S or something according to wintasks but i put it on a block list from that so i only have a few seconds to glimpse at the virus at start up which copies itself back into the registry every time that happens

    completeting rest of step 11 brb when its done

    i finished all the steps and i found the scvhost.exe in the windows folder since it was hidden and deleted it and now it doesnt run at start up and wont copy its files into registry i think im safe from stuff now except im wondering why my documents and settings folder always auto makes itself read only if you might know what i could do to fix it would help alot thanks

    and for the hjt log
     
  6. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    You did not post an AVG Antispyware log as requested.

    Your documents and settings folder is supposed to be read only, so no problem there. It`s a Windows protected OS folder.

    Your HJT log is clean.

    Regards Howard :)

    This thread is for the use of fatalpastry only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  7. fatalpastry

    fatalpastry TS Rookie Topic Starter

    yeah sorry for the avg log forgot to save =(
    thanks for clearing up the read only thing and thanks so much for being so helpful i would have probably had to reformat just to get rid of that scvhost
    =)
     
  8. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

    Did AVG Antispyware find anything? Perhaps you`d like to rescan with AVG Antispyware and if it finds anything, post the log file?

    Turn off system restore.(XP/ME only) See how HERE.

    Now, turn system restore back on. This will have deleted all your old restore points and any nasties that are in them. It will also have created a new, clean restore point.

    Regards Howard :)

    This thread is for the use of fatalpastry only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in our security and the web forum.
     
  9. fatalpastry

    fatalpastry TS Rookie Topic Starter

    avg didnt find anything the first time and yeah i scanned again and nothing was found comp "seems" to be clean lol. I did what you said for the system restore and i think im set, thanks again =)

    but a quick question what firewall/anti virus do you think is the best? sorry if theres already a thread about it but was just wondering
     
  10. howard_hopkinso

    howard_hopkinso TS Rookie Posts: 24,177   +19

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...