TechSpot

SERIOUS Windows XP Home problems - suspected virus(es)

By Screwdriverone
Jan 2, 2006
  1. Hi all,

    I have been banging my head against a brick wall for a while now and need some serious help. Two days ago my pc wouldnt start, saying it had a problem with the config file in the windows\system32. I restored the system with instructions from the web (microsoft) and now I seem to have other issues that I cant sort out.

    Once all the device drivers reloaded after reboot (pnp), I now find the following programs/applets etc dont work....
    1) Windows update - wont download SP2 even though it is already installed...
    2) Norton Antivirus (and auto protect - cannot start)
    3) Windows Firewall (cannot access start the ICS or ICF )
    4) System restore points are now all gone.

    Also, none of the add/remove buttons in the add/remove programs section of control panel are visible so I cannot load or unload any patches or programs,

    I have loaded and scanned (in safe mode) NOD32 antivirus and it has cleaned/deleted about 26 variants of the same couple of worms/trojans, but I suspect my registry may be corrupt and this is why nothing seems to work...possibly due to the dodgy info on how to recover.


    please help... any ideas would be appreciated
     
  2. iss

    iss TechSpot Chancellor Posts: 1,994

    Your best option is to reformat and reinstall windows.
     
  3. Screwdriverone

    Screwdriverone TS Rookie Topic Starter

    ummm, thanks, I am downloading the SP2 package to see if that helps by installing it and fixing links / registry.

    My pavilion (problem PC) has built in Disk image of the XP disk in a recovery section on it and the instructions tell me to hit f10 on the HP screen (doesnt work - surprise surprise) so I dont know how well reformatting and reinstalling will work as I dont have a physical XP home disk.

    Also, the windows installer seems to be disabled as I cannot install programs (or remove them for that matter - such as Norton Antivirus (it tells me to do this to fix its problem and I cant))

    Any other suggestions that might help?
    Thanks
     
  4. RoadKiller

    RoadKiller TS Rookie Posts: 22

    I agree to you iss.
     
  5. Screwdriverone

    Screwdriverone TS Rookie Topic Starter

    OK,some progress made.

    I have installed SP2 and this has fixed the installer problem and the microsoft update is now working.

    Norton Anti virus is now OK and is currently scanning.

    I think that the problem now points to the registry and the fact that the restore cannot track the status of programs installed since the restore point was created.

    Any idea of how to restore the program indentities in the add/remove program section?

    I can see the programs but the remove button is gone on the programs on all of the old ones (the new NAV install is OK as are all the other programs updated since SP2 was loaded recently)

    I think this is a registry problem as the registry doesnt know of these programs from an add/remove status.

    BTW programs all still work, just can modify them from control panel, have to manually remove or update them.

    Thanks
     
  6. Samstoned

    Samstoned TechSpot Paladin Posts: 1,018

Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...