Setting Up Multiple Monitor with 2 Graphics Card in Eyefinity

By Kdtut'z
May 27, 2014
Post New Reply
  1. JC713

    JC713 TechSpot Evangelist Posts: 6,685   +870

    Kdtut'z likes this.
  2. Kdtut'z

    Kdtut'z TechSpot Enthusiast Topic Starter Posts: 28

    Ah Ok Thanks @JC713 But Can't Understand? If you have visuals maybe I can understand?
  3. JC713

    JC713 TechSpot Evangelist Posts: 6,685   +870

    Would this help :D? It is a bit outdated but looks like it could help.
    Kdtut'z likes this.
  4. Kdtut'z

    Kdtut'z TechSpot Enthusiast Topic Starter Posts: 28

    :) Ok I'll Review It
  5. Kdtut'z

    Kdtut'z TechSpot Enthusiast Topic Starter Posts: 28

    @JC713 I can understand but here is the problem
    I attached pictures

    1st thing is that I can't group all three monitors to make it as 1 only the two
    and I think it is in the connection problem maybe? see pics for details

    Attached Files:

    • 222.jpg
      222.jpg
      File size:
      238.7 KB
      Views:
      7
    • 222.jpg
      222.jpg
      File size:
      208.5 KB
      Views:
      6
  6. Spykezxp

    Spykezxp TechSpot Booster Posts: 133   +19

    You can try the following adapters and you will be able to connect all 3 monitors to 1 card:
    SAPPHIRE 100924 Active DisplayPort Adapter
    Link Depot HDMI-DVI-2 6.56 ft. HDMI to DVI Cable M-M - OEM
    I have three monitors setup that way on one video card and it works fine for me. According to what I have read on multiple sites, if you are trying to get Eyefinity to work, you must have one monitor connected with a Display Port connection. It has to either be a monitor that has a Display Port connection or you must have an "Active" Adapter, not a "Passive" one. Trying to make this easy for you, so my suggestion (and you can take it or leave it), but I would buy the adapters that I have listed above and use those to connect ALL 3 monitors to 1 video card. At that point you can get Eyefinity to work properly.
  7. Kdtut'z

    Kdtut'z TechSpot Enthusiast Topic Starter Posts: 28

    I have already try what you've said and it worked 2 DVI and HDMI
    but how about the other card I have I cannot use it? it will be useless?
    All I want is just to use all cards :/
  8. JC713

    JC713 TechSpot Evangelist Posts: 6,685   +870

    Kdtut'z likes this.
  9. GhostRyder

    GhostRyder TechSpot Evangelist Posts: 2,131   +493

    When I get home ill show you with some screenshots how I setup my eyfinity if this does not help enough. I run 3 R9 290X cards and right now 3 1920x1080p monitors in eyefinity mode.

    A few things to note:

    1: You do not have to plug into both cards the monitors to use both for eyefinity and crossfire combination, otherwise I would have to split between all three cards.

    2: You have to use an active display port or adapter on one of the monitors to activate eyefinity normally. Keyword there is normally because Sapphire has a thing called Flex Eyefinity which allows you to break the molding and do some odd combinations for eyefinity. LINK. Your Sapphire card is included on the list or was at least linking to the Flex page so I assume it has the same features to do this.

    3: You need to actually hook up to one card for this to work right. Try hooking into the top card only with 2 DVI and the other either with a Display port to active display port adapter or the likes.

    Currently I have my monitors hooked up via HDMI by using the Display Port to Active DVI Adapter and the 2 DVI spots on my top 290X.
  10. Kdtut'z

    Kdtut'z TechSpot Enthusiast Topic Starter Posts: 28

    Ahh ok THANKS it seems that Sapphire is strict on connections you said I need only 1 card? again how about the other? meaning I cannot use both?
     
  11. GhostRyder

    GhostRyder TechSpot Evangelist Posts: 2,131   +493

    You use both cards but you cannot split your monitor connections between them. Basically you hook up all three monitors to the top card in the ways defined above, the second card is in the computer hooked up to the first via cfx bridge and then you setup eyefinity in catalyst control center. When gaming, both cards are going to be used to give you better fps while eyefinity is enabled or even when on a single monitor.

    You just can't split your monitor cables between them, but both cards will be used.
  12. Kdtut'z

    Kdtut'z TechSpot Enthusiast Topic Starter Posts: 28

  13. Kdtut'z

    Kdtut'z TechSpot Enthusiast Topic Starter Posts: 28

    :) @GhostRyder I just want to make clear my Sapphire R9 270x is not a Flex Edition? and I will connect all monitors on 1 card the to use the other one I will just make to cfx bridge to just give good fps no more connection on the 2 card?


    BTW Do You have screenshots? :) of yours
    Last edited: May 28, 2014
  14. GhostRyder

    GhostRyder TechSpot Evangelist Posts: 2,131   +493

    Yours is listed as a Flex edition according to the site (Most upper sapphire are).

    Your cards just need that bridge to communicate with eachother and the nor mal power hookups with all monitor cables on the top card. After setting up eyefinity, AMD Catalyst will take care of the rest.
  15. Kdtut'z

    Kdtut'z TechSpot Enthusiast Topic Starter Posts: 28

    @GhostRyder Just to make things clear :) I will connect all monitors to one card then set it to eyefinity right?
    How can I use the other card? what settings will I need or do? It is already connected via Crossfire Bridge will just leave it like that no more settings to adjust?
  16. GhostRyder

    GhostRyder TechSpot Evangelist Posts: 2,131   +493

    You have to put that orange (normally orange) ribbon cable that says crossfire on the sides of both cards connected together to enable CFX. Then just plug all monitors up to the top card and you should be able to enable eyefinity in CCC (AMD catalyst).
    Kdtut'z likes this.
  17. Kdtut'z

    Kdtut'z TechSpot Enthusiast Topic Starter Posts: 28

    Already Did that Thanks how about that CFX I mean in game is there will a setting that will enable the second card?
     
  18. GhostRyder

    GhostRyder TechSpot Evangelist Posts: 2,131   +493

    It should already be defaulted to on, in CCC, under Performance theres a tab that should say Crossfire. It should then just have 2 settings for you, crossfire enabled or crossfire disabled so just make sure it says enabled and your all set.
  19. Kdtut'z

    Kdtut'z TechSpot Enthusiast Topic Starter Posts: 28

    Ahhh ok got it

    THANK YOU Very Much @GhostRyder Great Great Help :) and @JC713 for Letting you know the Problem :D
    GhostRyder and JC713 like this.
  20. JC713

    JC713 TechSpot Evangelist Posts: 6,685   +870

    Glad everything is working out. If you have anymore questions come back! Glad @GhostRyder could help since I do not know much about multi-monitors.
    Kdtut'z likes this.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.