TechSpot

slave hard drive wont show up

By pcrepairs247
Apr 27, 2006
  1. hi people, i jsut bought a sata maxtor 160 gb hard drive about an hour ago. av popped it in my pc its recognises it in bios on load up, however it wont show up in windows. when i go to control panel/admin tools/computer management its displays the secondary hard drive as not iniialzed, and not allocated. what does this mean, how can i get this bad boy working!!

    some one plz help
     
  2. TypeX45

    TypeX45 TS Rookie Posts: 216

    Have you tried formating the drive through a setup disk or through a program like partion magic?
     
  3. Rik

    Rik Banned Posts: 4,985

    You should be able to right click on it and select format.
     
  4. TypeX45

    TypeX45 TS Rookie Posts: 216

    But if no partiton was created then you would not be able to just right click it.
     
  5. Sean

    Sean TS Rookie Posts: 131

    When you install a new drive, most of the time you have to format it in Disk Managment, it won't show up in mycomputer, go to Control Panel==>Administrative Tools====>Storage===>Disk Managment===>then double click the drive you added, then choose a drive letter and Name then format to NTFS.


    -sean owns your base's.
     
  6. lamensterms

    lamensterms TS Rookie Posts: 85

    you need to partition your drive. go into computer management - storage - disk management and right click your new drive and partition. you will need to assign a drive letter, etc. after this it is a good idea to format(you may need to anyway)
     
  7. Sean

    Sean TS Rookie Posts: 131

    ...that's what i exactly said duhh duh duhhhhh
     
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.