small probs after virus deletion

By francisosborne
Jan 6, 2007
Topic Status:
Not open for further replies.
  1. hey, I accidenlty downloaded a virus, me being stupind enough not instaling anti-virus app when i first got new computer i never knew untill weird things started to happen.
    my desktop - when i rightclick it all it has in the menu is Refresh, Paste, Paste Shortcut and Properties
    and in firefox my imported bookmarks dissapered.
    and when i started up windows it said there was sum sort of registery error but some files backups or suthin restored registery and restore was sucsseful
    this drew the line soo i downloaded avg and did a complete scan
    9 threats

    same virus's over 9 files

    a trojan Backdoor.Subseven and trojan Downloader.Zlob.FWR


    the files where either moved to vault or deleted and then i restarted computer and then wiped files from vault... but the effects i noticed still remained exept the registry 1 it didnt show up when i started up.


    what is problem registry error, virus's still remain (PLEASE GOD NO)?
    thanks
    please help
  2. kitty500cat

    kitty500cat Newcomer, in training Posts: 2,407   +6

    Hello and welcome to TechSpot.

    Please read this thread: Read this before deciding whether to clean or reformat

    Depending on what you use your computer for, you may want to reformat instead of cleaning it.

    If, after reading the above thread, you decide to clean your system, read this thread here: Virus/spyware/trojan preliminary removal instructions. Follow all the instructions exactly, then post fresh HJT and AVG logs as attachments into this thread.

    Cheers :)

    This thread is for the use of francisosborne only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in the Security and the Web forum.
  3. francisosborne

    francisosborne Newcomer, in training Topic Starter

    sorry about late reply... i followed the guide step my step the scanners didnt find much and im on holiday at a friends house and i cant seem to access the internet over there network and its a pretty simple i have also noticed that when i start up ma computer there is an error from windows defence saying that the service had couldent start but anyways here is my hjt log and avg anti spyware log
  4. kitty500cat

    kitty500cat Newcomer, in training Posts: 2,407   +6

    Have HJT fix this entry:

    O4 - HKLM\..\Run: [Alcmtr] ALCMTR.EXE

    Other than that, your HJT log is clean.

    Go into C:\Windows, and delete the file alcmtr.exe (if there).

    Go into C:\WINDOWS\system32, and delete actskn45.ocx (if there). Other than that, I think your system is cleaned.

    Cheers :)

    This thread is for the use of francisosborne only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in the Security and the Web forum.
  5. Rik

    Rik Banned Posts: 4,987

    Unfortunately that is not all that is wrong with your system.
    What kitty500cat says needs to be done but in addition you need to do the following.

    You might want to copy and paste these instructions into a notepad file. Then you can have the file open in safe mode, so you can follow the instructions easier.

    Turn off system restore.(XP/ME only) See how here.> http://www.bleepingcomputer.com/forums/tutorial56.html

    Boot into safe mode, under your normal user name(NOT THE ADMINISTRATOR ACCOUNT). See how here.> http://www.bleepingcomputer.com/forums/tutorial61.html

    In Windows Explorer, turn on "Show all files and folders, including hidden and system". See how here.> http://www.bleepingcomputer.com/forums/tutorial62.html

    Open your task manager, by holding down the ctrl and alt keys and pressing the delete key.

    Click on the processes tab and end process for(if there).

    Sample Toolband Serach
    MENUSEARCH

    Close task manager.


    Go to add remove programmes in your control panel and uninstall anything to do with(if there).

    Sample Toolband Serach
    MENUSEARCH


    Click start/run and type services.msc into the run box and press the enter key.

    When the window appears, maximise it. Double click on the following services(if there) and select stop if they are running. Set the startup type to disabled. Click apply/ok for each service you disable.

    ToolBand.dll

    Close the services window.

    Run HJT with no other programmes open(except notepad). Click the scan button. Have HJT fix the following, by placing a tick in the little box next to(if there).

    O8 - Extra context menu item: &Sample Toolband Serach - res://C:\WINDOWS\system32\ToolBand.dll/MENUSEARCH.HTM
    O9 - Extra button: (no name) - {e2e2dd38-d088-4134-82b7-f2ba38496583} - %windir%\Network Diagnostic\xpnetdiag.exe (file missing)
    O9 - Extra 'Tools' menuitem: @xpsp3res.dll,-20001 - {e2e2dd38-d088-4134-82b7-f2ba38496583} - %windir%\Network Diagnostic\xpnetdiag.exe (file missing)

    Click on the fix checked button.

    Close HJT.

    Locate and delete the following bold files and/or directories(if there).

    C:\WINDOWS\system32\ToolBand.dll/MENUSEARCH.HTM

    Reboot into normal mode, turn system restore back on and rehide your protected OS files.

    Let us know if that fixes your problem, if not, post a fresh HJT log in this thread.



    This thread is for the use of francisosborne only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in the Security and the Web forum.
  6. francisosborne

    francisosborne Newcomer, in training Topic Starter

    em yeh that alcmtr looks like something to do with my sound driver it has same name but ill delete anyways i guess i could probs just reinstall it of the web if there is a prob...
    and i know u typed (if there) but thought i would just let you know
    actskn45.ocx,Sample Toolband Serach
    MENUSEARCH, ToolBand.dll, C:\WINDOWS\system32\ToolBand.dll/MENUSEARCH.HTM where all missing. and sadly problems still persist here is my hjt.txt log

    thanks for help guys btw

    ps this might make my problem more complicated lol but what i said in my last post wasnt really true i can access internet everything exept websites and msn limewire, skype, pop3 they can all connect fine just web (port 80) and what ever port msn uses lol
  7. Rik

    Rik Banned Posts: 4,987

    I can see nothing nasty in your latest HJT log.

    Please describe all problems and popups you till have and perhaps a screenshot or 2 will help.


    This thread is for the use of francisosborne only. Please don`t post your own virus/spyware problems in this thread. Instead, open a new thread in the Security and the Web forum.
Topic Status:
Not open for further replies.


Add New Comment

TechSpot Members
Login or sign up for free,
it takes about 30 seconds.
You may also...


Get complete access to the TechSpot community. Join thousands of technology enthusiasts that contribute and share knowledge in our forum. Get a private inbox, upload your own photo gallery and more.