TechSpot

So WEIRD: New windows error @ startup & now MSN Messenger doesn't work!

By rwnewson
Jan 10, 2005
  1. I seriously have no idea what to do about this problem and its very important to me since MSN Messenger is my most used form of communication!

    Recently I installed AVG Antivirus Free Edition on my Windows 2000 computer. All seemed fine except even more recently. Now whenever I'm on the web I repeatedly get a virus alert from AVG and a windows message saying that the file: C:\Documents and Settings\Ryan\Local Settings\Temp\THIAFB.tmp\polall1r.exe could not be copied. (I suppose blocked by AVG). Every time I get this I click "Heal" and all seems to be well.

    Ever since these problems, whenever I startup windows I get an error message: "Some system files are of unrecognized versions. Insert Windows 2000 CD to restore original files". It does not say which files. If I insert my CD, the message goes away - but then appears on next restart!

    I might be able to ignore these constant error messages except for one problem... ever since MSN Messenger doesn't work! Whenever I try to signin it says "Could not login to .NET system. Try again later". I reinstalled Messenger and it didn't help. ICQ works and the internet works... This is the only thing that doesn't.

    I have a router but my Messenger had been working for months previous to this problem. Other computers on the router are able to run Messenger as usual. I checked connection settings on MSN and all seem to be correct. I clicked "Connection Troubleshooter" but it keeps freezing at "Detecting network settings..."

    In SUMMARY - AVG seems to have somehow caused system files to change and Windows can't fix them. This has caused only one problem which is that MSN Messenger won't login to .NET system.

    WEIRD EH?

    I can't seem to figure out what to do... My HiJackThis scan is included just for kicks. CAN ANYONE HELP??? Thanks!!!!
     
  2. vegasgmc

    vegasgmc TechSpot Chancellor Posts: 1,377

    Have you checked the AVG support site?
     
  3. Mictlantecuhtli

    Mictlantecuhtli TS Evangelist Posts: 4,345   +11

    Doesn't it have an option to just delete the file?

    Try booting to safe mode and running "sfc /scannow".
     
  4. rwnewson

    rwnewson TS Rookie Topic Starter Posts: 44

    I'll look up support on the AVG website tomorrow.

    But I tried to "delete the file" like you said and that worked, but did not affect my problems. The messages keep coming up. Also I rebooted in safe mode and typed what you said and it gave me the following error:

    "Windows File Protection could not initiate a scan of protected system files.
    Error code 0x000006ba [RPC server unavailable]"

    Does the sfc program use the internet? Because I was not connected at the time...
     
  5. rwnewson

    rwnewson TS Rookie Topic Starter Posts: 44

    YAY I FIXED IT!!
    Wow that took forever... I will post the solution so that other people can see if they have the same problem...

    This morning I still had no progress fixing my problem. Then I went on Windows Update out of desperation. I got an error message I've never seen before. It said that I couldn't connect to the Windows Update site. (Error code 0x800B0004) I thought maybe the same problem that was causing connection problems to .NET service was also causing problems with Windows Update. So I went to Windows Update support and they said I might need to "register" some dll's of mine (system files hmmm...). It said:

    1. Click on Start, Run and type "REGSVR32 SOFTPUB.DLL" (w/o the quotes). You should see a popup message that this process succeeded.
    2. Click on Start, Run and type "REGSVR32 INITPKI.DLL" (w/o the quotes). You should see a popup message that this process succeeded.
    3. Click on Start, Run and type "REGSVR32 MSSIP32.DLL" (w/o the quotes). You should see a popup message that this process succeeded.
    4. Try Windows Update again.

    [See http://v4.windowsupdate.microsoft.com/troubleshoot/ ]

    Well after this not only did Windows Update work, but my MSN MESSENGER WORKED!! and the computer stopped asking me for the Windows 2000 CD! All problems fixed just like that... I'm so happy.

    So thanks anyways guys.
     
  6. waqas0121

    waqas0121 TS Rookie

    Error

    I have a similar problem, my problem is that

    when i go on internet explorer it does not let me but when i go on mozilla firefox it works so the internet connection is fine.

    Also i cannot long into msn so i tried deleting it and downloading it again but now it does not let me download it because i am not connected to internet explorer the error comes up as "0x800b0004"

    Please Help i have tried everything that has been said on this thread.

    Thank You
     
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...