Some wierd stuff happening with my pc please help.

By Onkyo
Aug 7, 2007
  1. Ok as of yesterday i was playing a game enjoying my day off and all of a sudden my game freezes and i cant do anything, so i figured hey i will just restart the pc by hitting the restart button. When i hit the restart button it did its thing but when the bios load image came up all i saw was tons of symbols that looked like the dollar symbol $ and tons of letters and numbers it just wouldn't do anything.

    so i took out the video card cleaned it up popped it in again then symbols were not on the screen as much but still there. Now when it got to the windows loading screen there were no symbols at all but when you get to the desktop it wouldn't load.

    Now i called evga about the issue because i assumed it was it because when i finally got it loaded for 1 time loaded a game im fps was extremely low and i was lagging hardcore. they said it could be anything but did mention the motherboard or cpu or it could be the video card. now i am completely stuck and my pc will not load up to the desktop anymore all i get are red lines across the screen and $ symbols all over the screen.

    Could anyone out there please give some tips on what i should do ?

    Thanks in advance

    here are my pc specs:

    Athlon 64 X2 FX-60

    1 GIG (2 x 512 ) of corsair xms ram dual channel

    2 sata - 160 GIG drives, 1 - 300 GIG ide drive, and 1 - 120 GIG ide drive.

    asus a8n-e motherboard with the latest bios.

    EVGA Nvidia 7950 GT PCI-E

    All drivers installed are the latest out now.
  2. Cinders

    Cinders TechSpot Chancellor Posts: 872   +12

    You need to borrow a friends video card and see what happens. You have a nVidia card so borrow an nVidia. If your computer boots without funky symbols then you know it's the card, if it does boot with funky symbols then it's probably the motherboard.
  3. Onkyo

    Onkyo TS Rookie Topic Starter Posts: 17

    Thank you i will try that out and post what happens.
  4. WedgeoZ

    WedgeoZ TS Rookie

    What sort of antivirus are you running and had you recently scanned for any malicious software?
Topic Status:
Not open for further replies.

Similar Topics

Add New Comment

You need to be a member to leave a comment. Join thousands of tech enthusiasts and participate.
TechSpot Account You may also...